Register free!

The Green Industry's Resource Center


 
 
Thread Tools   Display Modes
  #1  
Old 07-26-2010, 11:29 AM
Rangr25's Avatar
Rangr25 Rangr25 is offline
LawnSite Member
 
Join Date: Mar 2007
Location: Saline Michigan
Posts: 43
hustler super z liquid cool

Hey just curious if you have heard of anyone having troubles with anti-freeze disappearing? It seems like i'm always adding fresh fluids every week. When i change the oil everything seems good there and i never see any puddles either so im not really sure where ifs going.
Posted via Mobile Device
  #2  
Old 07-26-2010, 11:44 AM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,753
I have heard of this before, not many times though.
I am not sure of the reason why it was happening though.

Pj
__________________
  #3  
Old 07-27-2010, 08:21 PM
Rangr25's Avatar
Rangr25 Rangr25 is offline
LawnSite Member
 
Join Date: Mar 2007
Location: Saline Michigan
Posts: 43
Alright just checking. It doesn't seem to be bothering the mower at all unless i forget to top it off and it starts buzzing at me in the middle of a job. It almost seems like it is disappearing quicker during this heat we have been getting.
Posted via Mobile Device
  #4  
Old 05-31-2012, 10:56 PM
RABBITMAN11's Avatar
RABBITMAN11 RABBITMAN11 is offline
LawnSite Bronze Member
 
Join Date: Feb 2006
Location: Carmel Indiana
Posts: 1,329
hustler cooling problem!

I have a 2006 hustler 26hp kaw and it keeps beeping water light after a hour of mowing? I checked coolant and it was a little low. Thought that was the problem but it did it again today. While mowing it feels as though there is excessive heat coming from the engine area. Help please, possible problems?
  #5  
Old 06-04-2012, 12:51 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,753
Quote:
Originally Posted by RABBITMAN11 View Post
I have a 2006 hustler 26hp kaw and it keeps beeping water light after a hour of mowing? I checked coolant and it was a little low. Thought that was the problem but it did it again today. While mowing it feels as though there is excessive heat coming from the engine area. Help please, possible problems?
Have you removed the radiator to make sure the cooling fins are free of debris on both sides?
Also, unbolt your hydro coolers and make sure they are free of debris on both sides also, do not use water to clean the fins out, you need to use air, water will just make the dirt and debris turn into a solid and make things worse.

Pj
__________________
  #6  
Old 06-12-2012, 11:10 PM
RABBITMAN11's Avatar
RABBITMAN11 RABBITMAN11 is offline
LawnSite Bronze Member
 
Join Date: Feb 2006
Location: Carmel Indiana
Posts: 1,329
Quote:
Originally Posted by mowerconsultant View Post
Have you removed the radiator to make sure the cooling fins are free of debris on both sides?
Also, unbolt your hydro coolers and make sure they are free of debris on both sides also, do not use water to clean the fins out, you need to use air, water will just make the dirt and debris turn into a solid and make things worse.

Pj
I did as you told me, havent had a chance to test it out!
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Layout Style:





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.com™ - Moose River Media
All times are GMT -4. The time now is 04:05 PM.

Page generated in 0.07821 seconds with 9 queries