Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 06-06-2012, 12:34 PM
sandking sandking is offline
LawnSite Member
 
Join Date: Jun 2012
Location: Springfield, OR
Posts: 3
RX 75 Problems

I went to start my RX75 this year and it would not turn over, put in new battery, safety switches and the motor turns over but will not start. I rebuilt the carburetor and installed new plug, it back fires every now and then when trying to start but still will not start. Any ideas what is wrong. Anyone know where I can get a technical manual?
Reply With Quote
  #2  
Old 06-06-2012, 05:49 PM
Restrorob's Avatar
Restrorob Restrorob is offline
LawnSite Fanatic
 
Join Date: Apr 2005
Location: Show'n my truck off !
Posts: 10,520
How about posting ALL the engine numbers so we can see what you've got....
__________________
Quote:
Originally Posted by piston slapper View Post
You never learn anything until you admit you don't know it all...

"Why go out preserved when you can go out beat up, worn out, sliding in sideways screaming, Holy Sh!t What A Ride" !!!
Reply With Quote
  #3  
Old 06-06-2012, 06:01 PM
sandking sandking is offline
LawnSite Member
 
Join Date: Jun 2012
Location: Springfield, OR
Posts: 3
Quote:
Originally Posted by sandking View Post
I went to start my RX75 this year and it would not turn over, put in new battery, safety switches and the motor turns over but will not start. I rebuilt the carburetor and installed new plug, it back fires every now and then when trying to start but still will not start. Any ideas what is wrong. Anyone know where I can get a technical manual?
It has a 9HP Kawasaki Engine
Reply With Quote
  #4  
Old 06-06-2012, 08:38 PM
Restrorob's Avatar
Restrorob Restrorob is offline
LawnSite Fanatic
 
Join Date: Apr 2005
Location: Show'n my truck off !
Posts: 10,520
Quote:
Originally Posted by sandking View Post
I went to start my RX75 this year ..........it back fires every now and then when trying to start but still will not start.

The above sounds like carbon build-up on the head/piston dried up while sitting, Then popped loose when trying to start it and got under the exhaust valve keeping it from seating properly.


A cylinder leak-down test would verify or eliminate this being the issue....
__________________
Quote:
Originally Posted by piston slapper View Post
You never learn anything until you admit you don't know it all...

"Why go out preserved when you can go out beat up, worn out, sliding in sideways screaming, Holy Sh!t What A Ride" !!!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 09:35 PM.

Page generated in 0.06318 seconds with 7 queries