search sponsored by:
Advanced Search

The Green Industry's Resource Center

Old 07-15-2012, 09:10 PM
sdf sdf is offline
LawnSite Member
Join Date: Jul 2012
Location: Gainesville, GA
Posts: 1
2012 Trimstar 48" Gas in Oil

I have a 2012 Trimstar 48" with 18 hours. It has the Kawasaki FS541V engine. The mower usually starts on the first or second pull. When trying to start the mower today, it took about 20 pulls. When the engine finally started, it was spewing gas and oil out of the exhaust. I cut the mower off and checked the oil and there was definitely gas in the oil. I plan on taking the mower to the dealer since it's under warranty. I am concerned about possible damage to the engine. Do you have any suggestions on what the problem might be?
Old 07-16-2012, 11:35 AM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,757
Without seeing it in person its hard to say.. but I would guess that debris got into the carb and got stuck in the float needle and seat and let gas run into the engine.


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Layout Style:

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 11:06 AM.

Page generated in 0.05893 seconds with 10 queries