Register free!
Search
 
     

Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 08-16-2012, 12:33 PM
garydale garydale is offline
LawnSite Senior Member
 
Join Date: Jan 2002
Location: Mount Airy, Maryland EST
Posts: 813
PG Magnum Ground speed

We have a long standing problem with our PG not pulling hills.
Great on flat ground but, loses speed on any grades.

Anyboby else finding or has solved this problem?
__________________
gary crutchfield
www.lawnaideplus.com
po box 630
mount airy, md 21771-0630
Reply With Quote
  #2  
Old 08-16-2012, 09:54 PM
RigglePLC's Avatar
RigglePLC RigglePLC is offline
LawnSite Fanatic
 
Join Date: Jul 2006
Location: Grand Rapids MI
Posts: 9,425
I am not an expert...but...it sounds like the air vane governor is not working. In theory--the governor should give it more gas when your speed slows down. More gas gives it more power. I had a few problems with my Ultra until I understood the problem. New throttle springs fixed it. It should take a good small engine mechanic about 60 seconds to fix this. Sometimes a slight bend to the throttle bell-crank will clear it up.
Reply With Quote
  #3  
Old 08-16-2012, 10:58 PM
amerigreen amerigreen is offline
LawnSite Member
 
Join Date: Aug 2009
Location: mn
Posts: 51
We have run into this problem. It was as simple as the drive belt getting glazed and slipping. Just a note we put a lot of hours on are machines and we have found the Gates PowerRated 6838 belt works the best. Its a green belt. Good luck.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 12:06 PM.

Page generated in 0.05736 seconds with 7 queries