Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #11  
Old 09-19-2012, 02:24 PM
290 290 is offline
LawnSite Member
 
Join Date: Oct 2010
Location: Sterling Heights, MI
Posts: 216
I would tell you to drain the oil and see if there is a metal sheen to it but this is a warranty issue and you should take it in right away. Never run an engine like this even under warranty because you are doing internal damage to it and all they may do is replace the head leaving you with the rest of the block that you ran in an overheated state.
Reply With Quote
  #12  
Old 09-19-2012, 02:39 PM
Ridin' Green Ridin' Green is offline
LawnSite Fanatic
 
Join Date: May 2011
Location: Michigan
Posts: 8,689
Yea, either of those two things could cause the symptoms he has.


OP

Before you take it in (if you haven't already) check the coolant level and color, and do the same with the oil. If it wasn't checked when new just because it was a new machine, it's possible that it didn't have enough of one or the other right from the start.
Reply With Quote
  #13  
Old 09-20-2012, 01:07 PM
290 290 is offline
LawnSite Member
 
Join Date: Oct 2010
Location: Sterling Heights, MI
Posts: 216
How about an update! Im curious as to what the problem was.
Reply With Quote
  #14  
Old 09-23-2012, 08:52 PM
trooper8870's Avatar
trooper8870 trooper8870 is offline
LawnSite Member
 
Join Date: May 2009
Location: Tennessee
Posts: 235
Have not got it in to dealer yet. They are aware of issue and are contacting Kubota about it. I will carry it in when the regional service man will be their. In the next few days or so. It is parked for now!
__________________
Reply With Quote
  #15  
Old 12-09-2012, 03:33 PM
MONTE MONTE is offline
LawnSite Senior Member
 
Join Date: Jan 2002
Location: Missouri
Posts: 791
Any updates?
Reply With Quote
  #16  
Old 12-09-2012, 08:27 PM
trooper8870's Avatar
trooper8870 trooper8870 is offline
LawnSite Member
 
Join Date: May 2009
Location: Tennessee
Posts: 235
I got rid of all three units. Only thing I got out of dealer was they could not find a problem. Regional serviceman never showed, so I became skeptical of my dealer. I was not too impressed with the units. The ZG227 was horrible. This unit is not worthy of being called a commercial unit. The two ZD331's were okay, but the power issues with the one and the fact that neither one of them cut worth a crap was enough reason for me to move on. Oh yeah the hydro systems sucked as well! I purchased three Hustlers and have been overly satisfied to date with them. I just hate I wasted the money on the Kubotas in the first place.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 03:03 PM.

Page generated in 0.06884 seconds with 7 queries