Register free!

The Green Industry's Resource Center



Reply
 
Thread Tools   Display Modes
  #1  
Old 10-13-2012, 07:41 PM
carguyrob carguyrob is offline
LawnSite Member
 
Join Date: Jan 2010
Location: Columbus Ohio
Posts: 192
Scag wildcat / 26hp lc Kawasaki problems

My wildcat is blowing an inline fuse (that unfortunately I believe was installed several years ago by my dealer to try to fix a warranty issue). There are no real trends associated with it blowing. The first time it blew I was off the mower moving some debris and the engine just shut off. The second time it blew when I turned on the blades, and the third and fourth times it blew when starting the engine. One of my friends had a similar problem with his tiger cub and it turned out to be the pto, but can it be the pto on mine when it will blow the fuse just by turning on the engine? I'd appreciate any help! Thanks in advance!
__________________
01 Chevy 2500HD w/Meyer Plow
13 Chevy 3500 SRW Diesel
7x20 Open Landscape Trailer
5x10 Open Landscape Trailer
07 Scag Wildcat 61"
14 Scag Tiger Cat 52"
14 Scag Vride 36"
07 Scag Z-Cat 36"
03 Scag SWZ 48"
00 Scag SW 32"
Redmax and Echo Trimmers and Blowers
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 09:50 AM.

Page generated in 0.05293 seconds with 9 queries