Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 11-02-2012, 07:49 PM
SVT SVT is offline
LawnSite Member
 
Join Date: Nov 2012
Location: McHenry, IL
Posts: 1
FeatherLite Leaf Blower issues (help please)

I have 3 questions.. I have a FeatherLite leaf blower I am trying to get running.. heres the run down...

It will start after a bunch of pulls and run for like 5 seconds then die, wont stay running.. I picked it up and heard something rattling, I opened the gas cap and the fuel filter was floating around in the gas tank.

QUESTION 1: So would the fuel filter being disconnected from the line cause it to not run for more then 5 seconds?

--------------------------------

There is 2 lines going to the Gas Tank, a thicker one (short) and a thinner one (long).. the thicker one had a plastic tube connected to it.. the thinner one had nothing.. I have no idea which one the fuel filter connects too. I tried putting it in the thinner tube but as I push it in the tube cracks and breaks apart and it wont connect to the thicker tube unless I pull out that plastic tube off that was already connected to it, but I am assuming that has to be there, so I have no idea where the fuel filter is supposed to connect.

QUESTION 2: Any idea which one the fuel filter connects too?

---------------------------------

Other then that, I just looked at the air filter, which was slightly dirty but not that bad. I have not looked at the spark plug yet since it got dark already and I could not see anymore.

If there is anything else I should look into as to why it would only run for about 5 seconds, please feel free to let me know.

Oh yea, almost forgot...

------------------------------------

QUESTION 3: I also I had to pull off the Prime Button to get enough slack on the fuel lines to be able to reach them, and when I did 2 gaskets came off, one is a thick rubber one and one was like a real thin plastic one.. I am not sure if the plastic one goes on top of the rubber one in the middle of the rubber one and the Prime Button, or if it goes under the rubber one, ANY help on that would be good too.


If pictures would help, I will grab some tomorrow, since it is dark out already I cant really get good ones right now...

Thanks in advance for any help.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 01:26 AM.

Page generated in 0.05608 seconds with 9 queries