Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 11-30-2012, 11:57 PM
ED'S LAWNCARE ED'S LAWNCARE is offline
LawnSite Senior Member
 
Join Date: May 2006
Location: Anderson, S.C.
Posts: 361
Exmark pump issues

Man it's been eons since I posted here. First off I'm no mechanic. I have a 04 exmark larzer with a 27 hp kohler.

Problem---mowing my yard (thankfully not customer) major smoke under the seat then the control levers would not work. I checked and the belt was broken...replaced the belt started motor noticed smoke coming from left pump. Could anyone tell me the proper steps on replacing the pump? I can take it to the dealer but trying to save money.

Also any input where I could buy an aftermarket pump?

Answers will be appreciated
Reply With Quote
  #2  
Old 12-02-2012, 08:18 AM
Monroe74 Monroe74 is offline
LawnSite Senior Member
 
Join Date: Jan 2006
Location: south central PA
Posts: 321
Exmark pump issues

What I do is wash the area where ill be working so I don contaminate the hydro fluid while taking everything apart.
Get some caps and plugs for hydro lines so you don't contaminate and lose fluid.
Remove belt
Remove hoses cap and plug hoses and pump
Remove linkage
Remove pulley
Loosen two bolts that hold pump on and remove from frame.
__________________
Do it better than the last Guy!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 06:13 PM.

Page generated in 0.06139 seconds with 9 queries