Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 02-05-2013, 03:49 PM
lawnguy 2 lawnguy 2 is offline
LawnSite Member
 
Join Date: Dec 2012
Location: Louisville, Ky
Posts: 11
Engine running rich and missing

Hi,

I have a 2010 Scag Turf Tiger 29 Kawasaki fuel injection with 329 hours. It tends to run rich with a mis. It has new air filters. I checked the fuel line for clogs and all is fine. I also drained the gas and put in some new supper unleaded. Before I run to the Scag dealer and run up a bill I thought it would be a good idea to see if anyone on here has any sugestions?

Lee
Reply With Quote
  #2  
Old 02-05-2013, 03:55 PM
Landrus2's Avatar
Landrus2 Landrus2 is offline
LawnSite Platinum Member
 
Join Date: Dec 2006
Location: Big apple
Posts: 4,690
I would start by checking fuel pressure
Reply With Quote
  #3  
Old 02-05-2013, 04:02 PM
Oldtimer Oldtimer is offline
LawnSite Bronze Member
 
Join Date: Apr 2000
Location: Pensacola, Florida
Posts: 1,378
Run to the Scag dealer.

Oldtimer
Reply With Quote
  #4  
Old 02-05-2013, 04:06 PM
piston slapper's Avatar
piston slapper piston slapper is offline
LawnSite Platinum Member
 
Join Date: Mar 2010
Location: Tampa Fl
Posts: 4,008
What do your sparkplugs look like...??? If you replace them...use the correct. NGK plug..
I had a customer that had a Kaw DFI...we changed the plugs...BPR2ES I think..anyway it would run perfect for 3 hours ..then start fouling plugs ....changed the plugs and it ran good for another 3 hours...again the same thing..
The problem ended up being the DFI connector was not sealing good and got moisture in the connection..
I believe there is dilectric grease in the connector ...but moisture finds a way in...
Check the connection at the black box...
__________________
If You Have All The Answers...Except The One You Need...You're Not Trying Hard Enough...
Do The Work
Reply With Quote
  #5  
Old 02-05-2013, 04:19 PM
Landrus2's Avatar
Landrus2 Landrus2 is offline
LawnSite Platinum Member
 
Join Date: Dec 2006
Location: Big apple
Posts: 4,690
I like the new look
Reply With Quote
  #6  
Old 02-06-2013, 08:08 AM
lawnguy 2 lawnguy 2 is offline
LawnSite Member
 
Join Date: Dec 2012
Location: Louisville, Ky
Posts: 11
They are very black and when I removed the threads are wet with gas. They are the correct NGK plugs. I talked to the Scag dealer about my problem a couple weeks ago and he mentioned I may have a bad sensor. Where are these and what do they look like?
Reply With Quote
  #7  
Old 02-06-2013, 08:21 AM
Landrus2's Avatar
Landrus2 Landrus2 is offline
LawnSite Platinum Member
 
Join Date: Dec 2006
Location: Big apple
Posts: 4,690
OK replace your oxygen sensor.
Reply With Quote
  #8  
Old 02-06-2013, 08:37 AM
Landrus2's Avatar
Landrus2 Landrus2 is offline
LawnSite Platinum Member
 
Join Date: Dec 2006
Location: Big apple
Posts: 4,690
Sorry look for it on your exhaust manifold looks like a spark plug with wire on top
Reply With Quote
  #9  
Old 02-06-2013, 01:41 PM
piston slapper's Avatar
piston slapper piston slapper is offline
LawnSite Platinum Member
 
Join Date: Mar 2010
Location: Tampa Fl
Posts: 4,008
Quote:
Originally Posted by joesimoes2 View Post
OK replace your oxygen sensor.
Kawasaki DFI...Digital Fuel Injection...does not have an O2 sensor...
Spend a little time in the school before you try to be an instructor...
__________________
If You Have All The Answers...Except The One You Need...You're Not Trying Hard Enough...
Do The Work
Reply With Quote
  #10  
Old 02-06-2013, 07:05 PM
lawnguy 2 lawnguy 2 is offline
LawnSite Member
 
Join Date: Dec 2012
Location: Louisville, Ky
Posts: 11
Yes, I looked everywhere on the manifold and couldn't find one.


Quote:
Originally Posted by piston slapper View Post
Kawasaki DFI...Digital Fuel Injection...does not have an O2 sensor...
Spend a little time in the school before you try to be an instructor...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 11:18 PM.

Page generated in 0.08265 seconds with 7 queries