Register free!
Search
 
     

Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 02-15-2013, 12:10 PM
moyer93 moyer93 is offline
LawnSite Member
 
Join Date: Mar 2011
Location: euclid, oh
Posts: 24
Z plug problem

having trouble pulling good plugs with my z plug, it is the new zplug with the front caster wheels. Anyone else having this problem, i've tried taking weights out also with no luck. It just seems like it pushes the dirt in creating a hole but not pulling out many plugs. My Ryan five aerator out pulls it by far.
Reply With Quote
  #2  
Old 02-15-2013, 01:23 PM
Service 1st Lawn Care Service 1st Lawn Care is offline
LawnSite Senior Member
 
Join Date: Nov 2008
Location: Illinois
Posts: 588
Sounds like the ground is too moist, lots of down pressure being applied if the ground is to soft that's what will happen. We have noticed we pull our best plugs when ground is actually dry.
Reply With Quote
  #3  
Old 02-18-2013, 10:24 AM
turfcobob turfcobob is offline
LawnSite Senior Member
 
Join Date: Jul 2005
Location: Lincoln, Nebraska
Posts: 863
Quote:
Originally Posted by moyer93 View Post
having trouble pulling good plugs with my z plug, it is the new zplug with the front caster wheels. Anyone else having this problem, i've tried taking weights out also with no luck. It just seems like it pushes the dirt in creating a hole but not pulling out many plugs. My Ryan five aerator out pulls it by far.
What do the inside of your tines look like. Rough and rusty cores may not pass thru thus plugging the tine. To polish the tine up you can put a 12 guage shotgun bore brush in a drill and clean the tines out.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 02:38 PM.

Page generated in 0.06023 seconds with 9 queries