Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #281  
Old 05-01-2013, 06:30 PM
stevo7896 stevo7896 is offline
LawnSite Member
 
Join Date: Mar 2013
Location: Fresno Ca
Posts: 13
Quote:
Originally Posted by Exact Rototilling View Post
I keep reading about how fast the Exmark is and how slow some of the ride-on on WB's are....?

I'm still waiting on a top speed difference between the TimeMaster and the TurfMaster.... ?
Posted via Mobile Device
On my exmark 30 ,its much faster than you can walk for a period of time .Its more like running speed. So I would assume the turf master is close in speed. Unless you are a jogger I think these mowers are fast . Basically faster than most can walk. Cant speak for the timemaster .
Reply With Quote
  #282  
Old 05-01-2013, 07:20 PM
Googus Googus is offline
LawnSite Member
 
Join Date: Mar 2013
Location: Charlotte, N.C.
Posts: 50
I am short so it is a slow jog for me
I just did a oil change and check all belts everything is to spec to manual.
Reply With Quote
  #283  
Old 05-03-2013, 07:52 PM
lawnsaspire lawnsaspire is offline
LawnSite Bronze Member
 
Join Date: Feb 2009
Location: Quincy, IL
Posts: 1,044
Quote:
Originally Posted by JFGLN View Post
They got mine fixed. Said there was a batch that was assembled improperly from the factory.
i called our exmark dealer and he said they had received no service bulletins. was it the toro or the exmark?
Posted via Mobile Device
Reply With Quote
  #284  
Old 05-03-2013, 11:12 PM
JFGLN's Avatar
JFGLN JFGLN is offline
LawnSite Senior Member
 
Join Date: Mar 2004
Location: Olympia, Washington
Posts: 661
Quote:
Originally Posted by lawnsaspire View Post
i called our exmark dealer and he said they had received no service bulletins. was it the toro or the exmark?
Posted via Mobile Device
Exmark. Back to the shop. Trany quit working again.
Reply With Quote
  #285  
Old 05-03-2013, 11:36 PM
rbljack rbljack is offline
LawnSite Senior Member
 
Join Date: Aug 2012
Location: Texas
Posts: 535
Quote:
Originally Posted by JFGLN View Post
Exmark. Back to the shop. Trany quit working again.
Did it quit all of a sudden? Maybe im just paranoid now, but it doesn't seem to be going as fast as when I first got it. Did yours slow down before giving out? im starting to be a little concerned..
__________________
Equipment:
2000 Chevy 3/4 Ton Long Bed 4x4
6.5x12 Dual Ramp Trailer
2012 21" Honda HRC-216 mower
2013 Exmark Commercial 30#1
2013 Exmark Commercial 30#2
2014 Exmark Lazer Z S Series EFI 52
Mclane 25" Reel Mower
2010 Husqvarna 21" mower
2008 Stihl FS250R Trimmer
2010 Stihl FS90R Trimmer
200? Stihl FC75 Edger
2013 Stihl BR 600 Blower
2013 Stihl HS81 t Hedge Trimmer
2014 Stihl SH 86 C E Blower Vac
2014 Stihl KM130R edger and trimmer shafts
200? Billy Goat AE550 Core Aerator
Reply With Quote
  #286  
Old 05-03-2013, 11:41 PM
JFGLN's Avatar
JFGLN JFGLN is offline
LawnSite Senior Member
 
Join Date: Mar 2004
Location: Olympia, Washington
Posts: 661
Quote:
Originally Posted by lawnsaspire View Post
i called our exmark dealer and he said they had received no service bulletins. was it the toro or the exmark?
Posted via Mobile Device
Quote:
Originally Posted by rbljack View Post
Did it quit all of a sudden? Maybe im just paranoid now, but it doesn't seem to be going as fast as when I first got it. Did yours slow down before giving out? im starting to be a little concerned..
You will know if its going bad. You can feel the gear kind of grinding. Like its spinning but not catching.
Reply With Quote
  #287  
Old 05-03-2013, 11:46 PM
sildoc's Avatar
sildoc sildoc is offline
LawnSite Silver Member
 
Join Date: Jun 2003
Location: Eagle Point, Oregon
Posts: 2,716
Quote:
Originally Posted by rbljack View Post
Did it quit all of a sudden? Maybe im just paranoid now, but it doesn't seem to be going as fast as when I first got it. Did yours slow down before giving out? im starting to be a little concerned..
Your belt has stretched, adjust and you will be good to go. Not a problem thus far on the toro. Seems to me that the same person keeps having the same problem???
__________________
What ever I do I must do it right!
Reply With Quote
  #288  
Old 05-03-2013, 11:51 PM
NEW CITY LAWN CARE LLC's Avatar
NEW CITY LAWN CARE LLC NEW CITY LAWN CARE LLC is offline
LawnSite Bronze Member
 
Join Date: Nov 2008
Location: Central Point, OR
Posts: 1,180
^^ yeah that's weird, you've gone through another trans?
Posted via Mobile Device
Reply With Quote
  #289  
Old 05-03-2013, 11:56 PM
JFGLN's Avatar
JFGLN JFGLN is offline
LawnSite Senior Member
 
Join Date: Mar 2004
Location: Olympia, Washington
Posts: 661
Quote:
Originally Posted by sildoc View Post
Your belt has stretched, adjust and you will be good to go. Not a problem thus far on the toro. Seems to me that the same person keeps having the same problem???
Are you implying that I'm not operating it properly? The dealer said they have replaced 2 tranys and someone else on here mentioned that theirs was bad.
Reply With Quote
  #290  
Old 05-03-2013, 11:57 PM
lawnsaspire lawnsaspire is offline
LawnSite Bronze Member
 
Join Date: Feb 2009
Location: Quincy, IL
Posts: 1,044
Quote:
Originally Posted by sildoc View Post
Your belt has stretched, adjust and you will be good to go. Not a problem thus far on the toro. Seems to me that the same person keeps having the same problem???

How do you adjust the belt on it? Just for future knowledge.
__________________
1995 Ford F-150
12X6 Aluminum Trailer
48 inch Scag V-Ride
Quick 36 Ninja WB
21" Honda HRX
Husqvarna 223L trimmer!
Echo Blowers
Kawasaki BP Blower
Toro & Ariens snowblowers

"I mow alone, with nobody else. Yes you know when I mow alone, I prefer to be by myself." Matt Thorogood

"All those in the memorial tombs will come out" -John 5:28

"The sea gave up the dead that were in it, and death and Hades gave up the dead that were in them"- Revelation 20:13
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 04:40 AM.

Page generated in 0.08684 seconds with 8 queries