Register free!


Reply
 
Thread Tools   Display Modes
  #1  
Old 03-24-2013, 12:39 AM
MEXANDME MEXANDME is offline
LawnSite Senior Member
 
Join Date: Apr 2004
Location: MYRTLE BEACH,SC
Posts: 396
Rainbird 5004 Slip Clutch

Did RB just come out with the slip clutch left stop adjustment or has it been out for a while?

Thanks!
Reply With Quote
  #2  
Old 03-24-2013, 09:51 AM
greenmonster304's Avatar
greenmonster304 greenmonster304 is online now
LawnSite Silver Member
 
Join Date: Jul 2007
Location: You Know
Posts: 2,544
It's been a while
Posted via Mobile Device
Reply With Quote
  #3  
Old 03-24-2013, 12:17 PM
DanaMac's Avatar
DanaMac DanaMac is offline
LawnSite Fanatic
 
Join Date: Mar 2002
Location: Somewhere in the state of CO
Posts: 13,097
I think they've had it from the start, although I have had many where it doesn't seem to work. And twisting the turret to the left feels like it will break.
Reply With Quote
  #4  
Old 03-24-2013, 12:31 PM
MEXANDME MEXANDME is offline
LawnSite Senior Member
 
Join Date: Apr 2004
Location: MYRTLE BEACH,SC
Posts: 396
DanaMac

DanaMac..........that is why I asked. Before they did feel like they were being forced and did not sound right. So, I would turn the whole body. The ones now turn to the left very smoothly. A video clip on the Rainbird site talks about the slip clutch for the left stop.

Hopefully, the ones we are getting now are the "new and improved" ones.

Thanks!
Reply With Quote
  #5  
Old 03-24-2013, 12:44 PM
greenmonster304's Avatar
greenmonster304 greenmonster304 is online now
LawnSite Silver Member
 
Join Date: Jul 2007
Location: You Know
Posts: 2,544
The slip clutch only works in the beginning. You can't go to a head that has been in the ground for a year and try it because it will strip.
Posted via Mobile Device
Reply With Quote
  #6  
Old 03-24-2013, 01:50 PM
Wet_Boots's Avatar
Wet_Boots Wet_Boots is online now
LawnSite Fanatic
 
Join Date: Mar 2005
Location: metro NYC
Posts: 40,708
I still miss the R-50 with its "forever" clutch
Reply With Quote
  #7  
Old 03-24-2013, 02:08 PM
MEXANDME MEXANDME is offline
LawnSite Senior Member
 
Join Date: Apr 2004
Location: MYRTLE BEACH,SC
Posts: 396
I installed thirty (30) R-50'S in my yard 12 years ago and not the first one has failed!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump






Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 07:49 PM.

Page generated in 0.06733 seconds with 9 queries