Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 06-30-2013, 09:26 AM
fat_angus fat_angus is offline
LawnSite Member
 
Join Date: Jun 2013
Posts: 2
Nebie - Grashopper Transmission Problem?

Hi,

I am not in the industry but use a Grashopper 721D front mount mower and am having problems. I am looking for help.

Engine starts fine
Blades turn fine when clutch is engaged


Problem:

The mower can no longer move forward. While both lever push forward, the right side doesn't engage with the transmission.

I am a newbie and not a mower expert. So any feedback will need to be in layman's speak.

Thanks in advance.
Reply With Quote
  #2  
Old 06-30-2013, 10:21 AM
goel's Avatar
goel goel is offline
LawnSite Member
 
Join Date: Mar 2010
Location: Freelton, Ontario Canada
Posts: 73
...............
Reply With Quote
  #3  
Old 06-30-2013, 11:08 AM
JCLawn and more's Avatar
JCLawn and more JCLawn and more is online now
LawnSite Platinum Member
 
Join Date: Sep 2009
Location: MI
Posts: 4,879
You have knuckle joints on your stearing linkage. Pop up the seat and compare the one side with the other. Move the steering lever and if its not moving the valve on the hydro pump something broke. It should be easy to spot what's wrong if you following the linkage.
Posted via Mobile Device
Reply With Quote
  #4  
Old 06-30-2013, 12:06 PM
fat_angus fat_angus is offline
LawnSite Member
 
Join Date: Jun 2013
Posts: 2
Thank you... after thinking it was the right hydro pump - $700.00, I realized that one of the belts was missing in the drive assembly. There is a double pulley off the drive shaft and only one belt. HA! Seems the part will only be about 15 bucks.

THanks,

fat_angus
Reply With Quote
  #5  
Old 06-30-2013, 12:21 PM
JCLawn and more's Avatar
JCLawn and more JCLawn and more is online now
LawnSite Platinum Member
 
Join Date: Sep 2009
Location: MI
Posts: 4,879
Quote:
Originally Posted by fat_angus View Post
Thank you... after thinking it was the right hydro pump - $700.00, I realized that one of the belts was missing in the drive assembly. There is a double pulley off the drive shaft and only one belt. HA! Seems the part will only be about 15 bucks.

THanks,

fat_angus
If its the old 721d's the pumps are easy to work on and parts are cheap.
Posted via Mobile Device
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 04:34 PM.

Page generated in 0.06345 seconds with 9 queries