Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 05-29-2013, 10:09 PM
RFreund RFreund is offline
LawnSite Member
 
Join Date: May 2013
Location: McHenry, IL
Posts: 1
Scag SWZ Relay Short

Scag 61" walk behind
Model: SWZ - 20CVE
Serial No: 14150534 (yes the mower has a some hours on it)

There seems to be a short somewhere that is draining the battery. I can hear a clicking noise in the relay when I connect / disconnect the relay and the battery is charged. The draw is pretty good and drains the battery quickly. I was wondering if there were any ideas on where the short might be. I have scoured over the wires looking for a frayed wire or something similar that might be causing the short but I could not find anything.
I now charge/jump the battery at start up in order to get it started.
Also just recently the mower deck stopped working after a few minutes of mowing. I first thought that the belt tension may be an issue or a stiff pulley wheel? However I checked the belt tension and it seemed ok (belt is a bit worn). So I am wondering if the battery/short issue is somehow related to the mower deck...

Any input is greatly appreciated.
Thanks!
Reply With Quote
Reply

Tags
electric short , relay , scag

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 10:25 AM.

Page generated in 0.05222 seconds with 7 queries