Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 06-24-2013, 09:47 AM
TForan TForan is offline
LawnSite Member
 
Join Date: Apr 2012
Location: MI
Posts: 25
Toro Timemaster drive problem

My PP wasn't really working, so I tried adjusting the cable but still it barely moves. I noticed the cable flexes a lot when engaged.

Is the cable binding or might it be something else? Thanks!
Reply With Quote
  #2  
Old 06-25-2013, 02:55 PM
groundsmechanic's Avatar
groundsmechanic groundsmechanic is offline
LawnSite Member
 
Join Date: Jun 2008
Location: Lansing, MI
Posts: 107
Is the belt worn out? Did it come off the pulley? If you lift the rear of the machine and push the handle forward do the wheels turn? Are you sure you adjusted the cable the right direction? Down is tighter.
__________________
4 - 60" Exmark Next Lazer Z 27hp
4 - 72" Exmark X-series 34hp
2 - 12.5' Toro 4700-D
2 - Gator XUV 620i
2 - Gator XUV 825i Power Steering
2 - Toro Workman HDX 4200
Reply With Quote
  #3  
Old 06-25-2013, 03:00 PM
TForan TForan is offline
LawnSite Member
 
Join Date: Apr 2012
Location: MI
Posts: 25
Quote:
Originally Posted by groundsmechanic View Post
Is the belt worn out? Did it come off the pulley? If you lift the rear of the machine and push the handle forward do the wheels turn? Are you sure you adjusted the cable the right direction? Down is tighter.

Belt looks fine and yes the wheels will spin but it just doesn't have much power. I had the dealer pick it up today. Thanks for the help.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 02:35 AM.

Page generated in 0.05748 seconds with 9 queries