Register free!

The Green Industry's Resource Center





Reply
 
Thread Tools   Display Modes
  #1  
Old 04-17-2013, 08:00 PM
Cut It Close Cut It Close is offline
LawnSite Member
 
Join Date: Dec 2007
Location: NJ
Posts: 125
Wright Stander 36 issues

Hello again. We touched on this in another thread of mine but that thread wasn't specific to this mower. This 2004 Wright Stander I have really has some touchy, jerky controls. I bought it used and it has a newer 15hp kawi motor with 100 hours. I was told it was 2010 but turns out to be a 2004. When I was testing it out before I bought it I just figured it was operator error cause I had never used a Wright before just Bobcat ZTRs. I added the Amsoil Slip Lock and it hasn't really made a difference. My 2009 52" RH that I bought after I had gotten the 36" is smooth as butter I can let go of the controls and it will stop smooth but with this 36 I really have to brace myself when I'm going to go from forward to reverse because I feel like I'll flip over the machine that's how bad they are or it will pull to the left. It jumps and jerks around and if you are on rough turf forget it. Any ideas what could be the problem? My lawn mower shop who use to be a wright dealer said ultimately I have to replace the hydros which I have no money for right now. Is there an adjustment that can be made. The control levers seem like they are too easy to move forward and backward where the 52 gives you a little more resistance which I like.

Also is there anything that can cover the motors that are on the inside of platforms where wheels are. I feel like my boots are melting and they are always sliding underneath that area. I know the later models fixed that issue or redesigned it.

Thanks
Reply With Quote
  #2  
Old 04-18-2013, 10:31 AM
WrightCommercial WrightCommercial is offline
Sponsor
 
Join Date: Apr 2008
Location: Frederick, MD
Posts: 508
Cut It Close,

Not knowing how many hours are on the unit you need to check some of the wear points in the controls. A common one on the early models is the clamps that hold the pump hoops to the pump shaft on the left side of each pump. It is a folded piece of steel that over time can get egged out by the pump shaft. Will looking at the clamp reach up and move the control lever, the clamp and sahft should move at the same time, if you see the clamp move then the shaft their is paly in the clamp. If the gap at the back of the clamp is still open then you can tighten it with the rear allen bolt, if the gap is closed they will need to be replaced and the replacements will be a cast piece. Also check all the bronze bushings in the control levers and the return to neutral system pivot points down by the pumps. The springs in the system can be replaced if you feel they are causing the system to feel to loose, they act just like the springs on the current pumps and effect the feel of the system. If the hours on the mower are high a hydro fluid change would be a good idea also. Do the control levers bottom out on the stationary bar or do they stop before the bar, if stopping before the bar then they are riding the internal stops in the pump and should be adjusted to stop on the bar not before. If it still seems overly sensitive the control rods can be put in the slow holes which will take a little top speed but drop the sensitivity of the system. Make sure you check the system over before changing to the slow hole so any wear issues can be addressed.

Best Regards
Wright Mfg.
Reply With Quote
  #3  
Old 05-15-2014, 12:02 AM
tommy needs tommy needs is offline
LawnSite Member
 
Join Date: May 2014
Posts: 1
Wright Sentar Sport 36" Problems?

Hello, i have a question for you. We purchased a 2012 Wright Sentar Sport 36" RH last year with only 42 hours on it. It worked fine all year until about two weeks ago. It keeps coughing/hiccuping for some reason and will not stop.It sort of sounds like the engine wants to turn off. It is not as bad when the blades are going, but as soon as you turn the blades off it seems real bad. The guy over at the shop was saying he has had problems with the engine on it ( Kawasaki FS600v 18.5 HP ), but i would have thought it was something minor like a spark plug or gas filter. We cleaned everything and the problem is still happening. The exhaust also seems to keep making a popping noise. Any ideas on what is causing this to happen ? Any advice would help. I believe it is still under warranty since it is only a year old, but we are hoping it is not something huge. Thanks
Reply With Quote
  #4  
Old 05-15-2014, 12:16 AM
Cut It Close Cut It Close is offline
LawnSite Member
 
Join Date: Dec 2007
Location: NJ
Posts: 125
I had similar problems with my 2009 19hp 52" stander. I tried all the regular cheap fixes like plugs and air filter. even did a valve adjustment and still had issues. i replaced the coils during the off season and the mower is finally running strong with no issues.
Posted via Mobile Device
Reply With Quote
  #5  
Old 05-15-2014, 11:14 AM
WrightCommercial WrightCommercial is offline
Sponsor
 
Join Date: Apr 2008
Location: Frederick, MD
Posts: 508
tommy needs,

Also check for a vacuum leak, possibly a stuck valve or some Kawi's had an issue where they sucked in the intake manifold gasket believe that was related to a torque issue on the manifold bolts.

Best Regards,
Wright Mfg.
Reply With Quote
  #6  
Old 06-04-2014, 07:54 AM
kawakx125 kawakx125 is offline
LawnSite Senior Member
 
Join Date: Apr 2012
Location: lees summit, mo
Posts: 945
My controls on the 36'' RH have the same problem, nobody could ever find anything wrong, but it doesn't go back to neutral smoothly, i find i have to ''pop'' the controls back into neutral, especially the right side. been that way since the day i got it.

also touching base on this same mower, I received the parts yesterday for the gas tank, when i pulled the old guage out, the hole is not round. it's almost egg shaped so i'm not sure if that had something to do with the grommet failing. I snapped a pic of it with my phone that i could email you if you pm your email. I installed the new parts and seemed like a tight fit but not sure how long it'll last. i'll fill it up with fuel today and see if it leaks.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 07:40 AM.

Page generated in 0.09405 seconds with 9 queries