Go Back   LawnSite.comô - Lawn Care & Landscaping Business Forum, Discuss News & Reviews > Sponsor Forums - Discuss with Sponsors Directly > Lawn Mowing Equipment & Accessories * * * * SPONSOR FORUMS > Hustler Turf Equip
User Name
Password
Home Products Find a Dealer News About Us Contact Us Mark Forums Read


Hustler Turf Equip Lawn Mowers & Turf Care Equipment

Reply
 
Thread Tools Display Modes
  #1  
Old 07-15-2013, 01:01 PM
bigcheese2007 bigcheese2007 is offline
LawnSite Member
 
Join Date: Jul 2013
Location: Springfield Tn
Posts: 5
Pumps.

I have Super Z with the xr7 deck and the 31 hp motor on it and I was wondering if someone could give me some info on rebuilding one of the hydro pumps on it or direct me to a thread that already has this info. I'm pretty sure its the pump that's going out. The mower doesn't like to be loaded on the trailer at all and struggles going up hill some. Could it be the drive motor on it? Thanks!
Reply With Quote
  #2  
Old 07-15-2013, 01:26 PM
hustlermidwest hustlermidwest is offline
Sponsor
 
Join Date: Sep 2012
Location: Chicago, Ill
Posts: 537
Have you done any testing on the drive system? Flow test? PSI? Hate to see you invest time and money on a guess.
I'm on vacation so I'll let the field chime in on this.

Brian O
Reply With Quote
  #3  
Old 07-15-2013, 01:31 PM
bigcheese2007 bigcheese2007 is offline
LawnSite Member
 
Join Date: Jul 2013
Location: Springfield Tn
Posts: 5
No sir I haven't. It just shutters whenever you turn it and does it real bad whenever you are loading it on a trailer.
Reply With Quote
  #4  
Old 07-16-2013, 06:26 PM
Sharpcut 1's Avatar
Sharpcut 1 Sharpcut 1 is offline
LawnSite Senior Member
 
Join Date: Sep 2006
Location: Roseville, MI
Posts: 450
I will almost guarantee you're gonna need to do both. The wheel motor inner and outer shaft start stripping, causing the chattering your talking about. Metal shavings from shaft get in pump, both will eventually fail. Most of the time the wheel motor starts first, and then the pump. Just repairing or replacing pump isn't going to do anything if pressure is being lost in wheel motor.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:38 PM.

Forum Rules:

This hustlerturfequipment.com sponsored forum is administrator monitored. LawnSite.com does not allow any manufacturer competitor attacks and will strongly enforce this. If you want your discussion to be viewable by the public and responded to in a professional manner then please keep your discussions professional and to the point.

All discussions are viewed by the administration before being released to the public. Your post may not be made viewable for up to 48 hours. Please allow the manufacturer representative enough time to respond to your question or comment once made viewable.

LawnSite.com is not affiliated with the Excel Hustler company. This forum is provided by LawnSite.com to Excel Hustler in order to better server their customers


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
Lawnsite,  Plowsite, WeldingWeb, LawnCareSuccess, Everythinggreen, & Lawnbusiness.net are trademarks of Lawn Care Success, Inc

Page generated in 0.05884 seconds with 7 queries