Register free!

The Green Industry's Resource Center



Reply
 
Thread Tools   Display Modes
  #1  
Old 09-06-2013, 08:25 AM
TML's Avatar
TML TML is offline
LawnSite Senior Member
 
Join Date: Oct 2012
Location: Southern, ME
Posts: 641
WB grass catchers & stripes

I have a Packem grass catcher on my 36 Metro. I find it really messed w/ the stripes I think because it is a heavy catcher even without any grass and when mounted it is flush with the mower bottom. When it gets full I think the bottom bows down just a bit and brushes the grass underneath. The catcher itself works great and packs full.

Just asking if anyone with an Accelerator has experienced this and if they still get good stripes with it attached? I know they are lighter to begin with and the pictures I've seen appear that when mounted it is up at and angle slightly to the rear preventing it from brushing the grass? Trying to justify cutting my loses with the Packem and buying Accelerator. Yes 100% sure it is mounted correctly.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 07:36 AM.

Page generated in 0.04951 seconds with 9 queries