Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 11-07-2013, 10:22 AM
american dream american dream is offline
LawnSite Member
 
Join Date: Apr 2007
Location: murfreesboro, tn
Posts: 214
Walker hydro fan

Hey guys anyone know what would be causing my hydro fan on speed control to keep breaking. It looks very close to blower housing and I think the housing may have moved foward some,what would cause this?
Reply With Quote
  #2  
Old 11-07-2013, 04:12 PM
FerrisDiesel's Avatar
FerrisDiesel FerrisDiesel is offline
LawnSite Senior Member
 
Join Date: Nov 2007
Location: West Warwick, Rhode Island
Posts: 406
Quote:
Originally Posted by american dream View Post
Hey guys anyone know what would be causing my hydro fan on speed control to keep breaking. It looks very close to blower housing and I think the housing may have moved foward some,what would cause this?
I think you're dead on with that assumption. If you sucked up a stick, or something, it bends the impeller in the housing and moves the housing outward. I also noticed when I was changing out my blower housing last week, that if all the bolts are not tightened, it moves the housing as well.
__________________
RI Pesticide Applicators License
RI Full Hoisting License

http://www.facebook.com/pages/AWeave...12666792139719


http://www.aweaverlawncare.com


Rhode Island Lawncare/Landscapers Networking Thread
http://lawnsite.com/showthread.php?t=367380
Reply With Quote
  #3  
Old 11-07-2013, 07:34 PM
windflower windflower is offline
LawnSite Senior Member
 
Join Date: Feb 2013
Location: wilmington nc
Posts: 660
If the fan clears when installed and nothing is loose it may be debris, like pine cones, getting in there. On the walkers I've owned the blower bolts have enough stuff deposited on them that they never come loose.
Reply With Quote
  #4  
Old 11-07-2013, 07:36 PM
american dream american dream is offline
LawnSite Member
 
Join Date: Apr 2007
Location: murfreesboro, tn
Posts: 214
It's went through 4 in 2 days
Posted via Mobile Device
Reply With Quote
  #5  
Old 11-08-2013, 04:37 AM
mdghs mdghs is offline
LawnSite Member
 
Join Date: Nov 2012
Location: NY state
Posts: 31
Check your battery protector plate and make it is tight and not sliding over and hitting the fan. Also check the underside of the body/seat and make sure nothing is dropping down when you shut the body. Has the blower intake tube been altered in any way or removed and not put on properly?
Reply With Quote
  #6  
Old 11-08-2013, 08:07 AM
american dream american dream is offline
LawnSite Member
 
Join Date: Apr 2007
Location: murfreesboro, tn
Posts: 214
No blower has not been touched in over a year. One thing I did notice is sometimes now when you shut the hopper it does not line up on the blower Shute and it has to work its way into place
Posted via Mobile Device
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 05:02 PM.

Page generated in 0.07534 seconds with 7 queries