Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 05-11-2012, 11:35 PM
indy_gt indy_gt is offline
LawnSite Member
 
Join Date: May 2012
Posts: 3
Toro Timemaster 30" Just arrived today and it has the worst cut I've ever seen

Just got one shipped in today and cut the lawn tonight. I last mowed last five days ago via a 22" mower at 3.5" tall and today mowed with the Toro 30" at 3.5" (front and rear) with the side chute closed (mulching). We've been dry for a few days and the grass was dry.

This thing has the worst cut I've ever seen. Its not even close to being an even cut. Just right of center its leaving rows of missed grass. The Toro customer service line referred me to a local dealer to call on Monday. I dont see any mechanical defects as the blades engage fine. Anyone seeing this issue?

A few pictures are attached (links online for 30 or 60 days if your reading this post in the future).
Reply With Quote
  #2  
Old 05-11-2012, 11:47 PM
Lbilawncare's Avatar
Lbilawncare Lbilawncare is offline
LawnSite Bronze Member
 
Join Date: May 2002
Location: Illinois
Posts: 1,105
Try sharpening the blades, often new blades don't have a great edge on them or its covered with paint.
__________________
Just cutting the grass just doesn't cut it.
Reply With Quote
  #3  
Old 05-12-2012, 02:25 PM
indy_gt indy_gt is offline
LawnSite Member
 
Join Date: May 2012
Posts: 3
Blades are fine. Dealer is three weeks out on anything dropped off.
Reply With Quote
  #4  
Old 05-12-2012, 05:11 PM
Richard Martin's Avatar
Richard Martin Richard Martin is offline
LawnSite Fanatic
 
Join Date: Mar 2000
Location: Greenville, NC
Posts: 14,489
I saved your pictures to a library that isn't gone in 60 days.



__________________
Serving Greenville, Winterville and Ayden NC



Reply With Quote
  #5  
Old 05-12-2012, 05:35 PM
lawnboy dan lawnboy dan is offline
LawnSite Gold Member
 
Join Date: Oct 2005
Location: north florida
Posts: 3,433
the luster is off the pearl?
Reply With Quote
  #6  
Old 05-12-2012, 05:36 PM
sjessen sjessen is online now
LawnSite Bronze Member
 
Join Date: Jul 2004
Location: Knoxville, Tn
Posts: 1,553
Engine rpm's too low?
Reply With Quote
  #7  
Old 05-12-2012, 07:38 PM
unit28 unit28 is offline
LawnSite Bronze Member
 
Join Date: Mar 2007
Location: MN, A-noka CO.
Posts: 1,586
I wonder if you could get megmo blades for it
Reply With Quote
  #8  
Old 05-12-2012, 07:43 PM
Patriot Services's Avatar
Patriot Services Patriot Services is offline
LawnSite Fanatic
 
Join Date: Jul 2006
Location: Tampa FL
Posts: 8,326
Quote:
Originally Posted by unit28 View Post
I wonder if you could get megmo blades for it
I doubt it as those are timed blades and not staggered. Its too bad this mower is flopping as interest was so high.
Posted via Mobile Device
Reply With Quote
  #9  
Old 05-12-2012, 08:10 PM
NEW CITY LAWN CARE LLC's Avatar
NEW CITY LAWN CARE LLC NEW CITY LAWN CARE LLC is online now
LawnSite Bronze Member
 
Join Date: Nov 2008
Location: Central Point, OR
Posts: 1,180
Might be a dumb suggestion, but blade bolts tight? Belt tension ok?
Reply With Quote
  #10  
Old 05-12-2012, 08:12 PM
SSmith SSmith is offline
Banned
 
Join Date: Nov 2004
Location: Cincinnati, Ohio
Posts: 447
What a shame. Funny too because my Toro Personal Pace is an absolute beast.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 04:34 PM.

Page generated in 0.07991 seconds with 10 queries