Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 01-09-2014, 05:42 PM
exmarkking's Avatar
exmarkking exmarkking is online now
LawnSite Senior Member
 
Join Date: Mar 2008
Location: North Georgia
Posts: 970
Never in my life have a had so much trouble with hand helds

Our company bought all new redmax equipment in the year(2012).They ran great for the first year. Plenty if power, started right up every time, not a bit of trouble. All last year(2013) they have been nothing but trouble. Some pieces fire right up but have no power under full throttle, others are hard to crank and run good once you get them running. One piece is a extended reach hedge trimmer and it has ran like crap since new. Seems to lean out all the time, hard to crank, bogs down under full throttle. The odd thing is the blowers have never given us an issue. We run clean, fresh 93 octane from the same station in all equipment. We use high end synthetic 2 stroke oil in everything. The gas is never more than 4 days old since we only use 2 1/2 gallon tanks to store the fuel. We always change spark plugs, air filters, fuel filters. We keep everything greased and it's stored out of the weather. They never get wet. What drives me crazy is the non adjustable carbs on these machines. I know they are adjustable of you know how, but they aren't like the old school carbs with high, low, and idle knobs on the side. Do you think we got a bad batch? Do you think it's anything we have done or not done? Is it possibly the fuel even though the mowers and blowers don't have issues? I have no clue where to go from here considering the season starts back full time in feb-march for us. Just today I ran a weed eater that was stored for the past 2 weeks dry. When we put it up 2 weeks ago, I drained all the fuel out and ran it until it quit. Toady I put fresh fuel in it and it fired right up but never seemed to rev up and have good power under full throttle. Over the past year I have bought numerous carb rebuild kits, taken them apart and cleaned everything. Nothing seems to help. Do I need to buy all new equipment. Or new carbs? I think the carbs are somewhere around $70.00 a piece. Hell is rather just buy new equipment instead. So does commercial equipment only last 1 season now? It's not like we cut a million properties a year with these things! Oh I wish I could go back to the early 90's when you could adjust a carb and get real gas!!!
Posted via Mobile Device
Reply With Quote
  #2  
Old 01-09-2014, 05:47 PM
larryinalabama larryinalabama is online now
LawnSite Fanatic
 
Join Date: Jan 2008
Location: Ragland Al
Posts: 9,325
Ive been told Not to run 93 octane in air cooled engines.

Not that it matters but Im having terrible luck with my Sthil stuff.
Reply With Quote
  #3  
Old 01-09-2014, 05:48 PM
inzane's Avatar
inzane inzane is online now
LawnSite Bronze Member
 
Join Date: Jan 2012
Location: Dallas, GA
Posts: 1,488
i have a couple of redmax units with the different attachments. they are both a huge pain in the butt to start. i have also had an issue with the hedge trimmer attachment vibrating real bad, couldn't feel my hand for like a week one time.. lol. I got that worked out though. I bought them last year, I never want to use redmax again. My echo's from home depot that are over 10 years old are easier to start.
__________________

Servicing Dallas, Acworth, Kennesaw, & Woodstock, Ga
Reply With Quote
  #4  
Old 01-09-2014, 05:50 PM
loveitgreen loveitgreen is offline
LawnSite Member
 
Join Date: Sep 2013
Location: Farmington, NM
Posts: 25
I'd get the dealer to adjust them, if possible.
Reply With Quote
  #5  
Old 01-09-2014, 06:13 PM
easy-lift guy's Avatar
easy-lift guy easy-lift guy is online now
Sponsor
 
Join Date: Aug 2011
Location: Venice, FL. USA
Posts: 1,760
You can thank The EPA and CG. Hand held Equipment I believe will never be the same again.
easy-lift guy
Reply With Quote
  #6  
Old 01-09-2014, 06:21 PM
exmarkking's Avatar
exmarkking exmarkking is online now
LawnSite Senior Member
 
Join Date: Mar 2008
Location: North Georgia
Posts: 970
yeah, I was just ranting after thinking about it and wanted to hear from you guys. I think it's a shame that you have to deal like this with new commercial grade equipment.
Posted via Mobile Device
Reply With Quote
  #7  
Old 01-09-2014, 06:38 PM
retrodog's Avatar
retrodog retrodog is offline
LawnSite Silver Member
 
Join Date: Apr 2007
Location: Paris, Tx
Posts: 2,037
I have issues like this as a dealer...they have a 2 year warranty, honestly man most of the time if we replace the carb they run great. We even had some new ones that didn't run right, threw new carbs on them and they were good to go....on red max mainly, I have seen it on other brands but not as bad. Carbs really adjust idle they don't let you do top end adjustments anymore..
Posted via Mobile Device
Reply With Quote
  #8  
Old 01-09-2014, 06:40 PM
exmarkking's Avatar
exmarkking exmarkking is online now
LawnSite Senior Member
 
Join Date: Mar 2008
Location: North Georgia
Posts: 970
I would have to check if they are still under warranty. If so would it cover a carb? We do all the maintenance on equipment ourselves, but if it's covered under warranty they can fix it.
Posted via Mobile Device
Reply With Quote
  #9  
Old 01-09-2014, 07:33 PM
ed2hess's Avatar
ed2hess ed2hess is online now
LawnSite Fanatic
 
Join Date: Nov 2002
Location: Austin Texas 78727
Posts: 11,311
I work with a lot of 2 stroke handhelds and I find that it is real important to have adjustable carburetors. I don't see how putting new carb on will guarantee it will fix stuff. I have to adjust sometimes for extreme temperature changes. And as the units wear in that changes things. Try switching to the Echo line.
Reply With Quote
  #10  
Old 01-09-2014, 11:48 PM
MRCo. MRCo. is offline
LawnSite Member
 
Join Date: Nov 2013
Location: Franklin, NC
Posts: 194
Switching to Echo is switching to the same barrel valve carbs, so that's redundant.

Ok, I deal Redmax. I have very few issues at all. Have you looked at your ex ports? How did you store them?...seems weird they were good last year and this they play up. And why hasn't your dealer got them straight under warranty?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 08:19 PM.

Page generated in 0.07848 seconds with 7 queries