Register free!

The Green Industry's Resource Center



Reply
 
Thread Tools   Display Modes
  #1  
Old 02-18-2014, 07:33 PM
Big Bad Bob's Avatar
Big Bad Bob Big Bad Bob is offline
LawnSite Bronze Member
 
Join Date: Oct 2006
Location: zone 5
Posts: 1,062
charging problem

2005 Polaris 500. 3000 lb winch. Was working great. All of a sudden if I try to raise or lower the blade, the engine dies. If I hook a battery charger to the winch, it lifts and lowers no problem. In other words, if I idle the atv with the charger hooked to the battery, no problem. If I try to run the winch from the power of the atv, it idles good until I try to use the winch. Battery voltage is 12.5 volts so I think the sealed battery is ok. What could cause this? Engine will die instantly if negative cable is disconnected.
__________________
Price fairly but price to stay in business.

You can't charge extra because it takes you twice as long to do the job because you have crappy or outmoded equipment.

And, if they don't pay, put a shovel upside their head.
Reply With Quote
  #2  
Old 05-20-2014, 09:37 PM
firedude26 firedude26 is offline
LawnSite Senior Member
 
Join Date: Feb 2004
Location: Mich
Posts: 278
might be to late but, your battery may say 12.5 but it may not hold it under a load, ive had that problem. if not fixed put a load test on the batt.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 05:59 PM.

Page generated in 0.05391 seconds with 7 queries