Go Back   LawnSite.comô - Lawn Care & Landscaping Business Forum, Discuss News & Reviews > Sponsor Forums - Discuss with Sponsors Directly > Lawn Mowing Equipment & Accessories * * * * SPONSOR FORUMS > Hustler Turf Equip
User Name
Password
Home Products Find a Dealer News About Us Contact Us Mark Forums Read


Hustler Turf Equip Lawn Mowers & Turf Care Equipment

Reply
 
Thread Tools Display Modes
  #1  
Old 09-09-2003, 06:28 PM
SLC1234 SLC1234 is offline
LawnSite Member
 
Join Date: Jan 2003
Location: Central Connecticut
Posts: 42
Need Help with 4600

We have a 2000 Hustler 4600 Range wing, We have been
having a problem with it for almost a month. On one of the
wings the hydro filter keeps blowing gaskets off of it. I does
not matter what it is doing mowing, not mowing ect. IT blows
off and fluid goes every where. We have tried different filters
and such but it still keeps happening, we brought it to the
dealer and they could not find anything wrong with it. Just the
gasket is blowing off, for a quick fix in the field we just unscrew
the filter and put the gasket back on and it will last another
three hours or sometimes the rest of the day. Any suggestions
Let me know. Thankyou in advance.
Reply With Quote
  #2  
Old 09-09-2003, 09:58 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,751
Hmmmmm........
I am not a hydraulic expert by far...but I think there is something up with the pressures in that unit.
I will forward this info on to our customer service dept and see what they believe it to be.
I will post back as soon as I hear something (tomorrow).

Later
Pj
__________________
Reply With Quote
  #3  
Old 09-10-2003, 05:49 PM
SLC1234 SLC1234 is offline
LawnSite Member
 
Join Date: Jan 2003
Location: Central Connecticut
Posts: 42
PJ, Thankyou I will be waiting to hear from you. I talked to
a heavy equipment mechanic and he said to check the return
lines that one of them may be kinked or something, They dont
look it and all appear to be ok. But I will be waiting to see
what the factory has to say.


www.schmidtlawncare.com
Reply With Quote
  #4  
Old 09-10-2003, 06:01 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,751
I just got off the phone with the factory.
Our service manager said the same thing you heard from your heavy equipment guy.
Our service manager talked to Jim and Rocco @ Bacher and told them what hey need to look at, line kinks, hose routing, etc...etc..
So please call Bacher and get it scheduled to go back in there, they will get it taken care of.

Later
Pj
__________________
Reply With Quote
  #5  
Old 09-11-2003, 10:17 PM
SLC1234 SLC1234 is offline
LawnSite Member
 
Join Date: Jan 2003
Location: Central Connecticut
Posts: 42
Thankyou PJ, I dropped the Rangewing off at Bacher Corp. tonight, hopefully they can find the problem. I will let you know when I get it back. Thankyou again.

www.schmidtlawncare.com
Reply With Quote
  #6  
Old 09-28-2003, 05:44 PM
SLC1234 SLC1234 is offline
LawnSite Member
 
Join Date: Jan 2003
Location: Central Connecticut
Posts: 42
PJ, I am still having the problem with my 4600 Rangewing, Rocco at Bacher Corp. said that he has spoken with the factory and they said to check all the hoses for kinks and also to try a new filter assembly housing that the filter sits on, they did all that. I went and picked it up and within 45mins of mowing the gasket blew off the filter. Is there someone at the factory that Bacher could talk to, this is starting to get a little frustrating, it has been happening for almost 6 weeks now, and has been up at the dealer 5 times for the problem. Let me know what you find out. Thankyou very much.

www.schmidtlawncare.com
Reply With Quote
  #7  
Old 09-29-2003, 12:29 AM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,751
I will make some more phone calls and see what I can do.
Rocco has been talking to our main man in the service dept.
There must be something very hard to find, between Rocco and our service man, they have about 50 years of experience on Hustler's.

Pj
__________________
Reply With Quote
  #8  
Old 10-19-2003, 12:29 AM
kagney333 kagney333 is offline
LawnSite Member
 
Join Date: Oct 2003
Location: Finchville Kentucky
Posts: 10
You may have some sort of pressure relief valve on the unit, externally, from the hydorlic pump that is not relieving. Just a thought.

kag
__________________
kag
Reply With Quote
  #9  
Old 04-13-2012, 02:30 PM
BRPoese BRPoese is offline
LawnSite Member
 
Join Date: Apr 2012
Location: Whiteman AFB, MO
Posts: 1
Mechanic

We've had similar issues, and traced them to using Wix filters instead of OEM Hustler. Nothing wrong with Wix, per se, but on the Wix cross reference chart the Hustler(Excel) filter crosses to a Wix 51202. When you check the specs, Huster filters show a 10 micron, 40-50 gpm rating, while the Wix 51202 shows 5 micron, 28-30 gpm. Also, the seal on the Wix sits higher/above the end of the filter, while the Hustler/Excel filter is recessed into the end of the filter, so the seal cannot squirt out under pressure. We're basically trying to put too much flow through a too small hole. We went back to OEM filters and it seems to have fixed it.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:21 AM.

Forum Rules:

This hustlerturfequipment.com sponsored forum is administrator monitored. LawnSite.com does not allow any manufacturer competitor attacks and will strongly enforce this. If you want your discussion to be viewable by the public and responded to in a professional manner then please keep your discussions professional and to the point.

All discussions are viewed by the administration before being released to the public. Your post may not be made viewable for up to 48 hours. Please allow the manufacturer representative enough time to respond to your question or comment once made viewable.

LawnSite.com is not affiliated with the Excel Hustler company. This forum is provided by LawnSite.com to Excel Hustler in order to better server their customers


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
Lawnsite,  Plowsite, WeldingWeb, LawnCareSuccess, Everythinggreen, & Lawnbusiness.net are trademarks of Lawn Care Success, Inc

Page generated in 0.06844 seconds with 7 queries