Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 04-10-2004, 10:02 PM
heritage's Avatar
heritage heritage is offline
LawnSite Bronze Member
 
Join Date: Aug 2003
Location: New Jersey
Posts: 1,180
EH18 6 H.P. robin engine question

I just purchased a new 2003 piece of equipment with a robin engine. It sputtered at high rpm's so I went through the process of checking spark at all rpm's and was o.k. pulled off air filter thinking it might be a defective air cleaner with too small micron size......still sputters. Pulled off carb and cleaned the air bleed........still sputters. Ran the engine and turned off the fuel and after 3 seconds it ran great so I say o.k. the float is high or the viton tip on the needle valve is bad from having fuel sit in it for 2 years. Pull out the needle valve and that was o.k. The float is plastic or nylon and is not adjustable and it had no gas inside it.....so I am thinking that the float is defective even though it floats when I test it. Have you guys ever had a bad float in a new piece of equipment? What else would cause this problem? It is a fixed jet carb also.
Thanks for your input.......

Pete D.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 05:12 AM.

Page generated in 0.05983 seconds with 7 queries