Register free!

The Green Industry's Resource Center



 
 
Thread Tools   Display Modes
  #1  
Old 06-19-2004, 08:49 AM
TurfPro TurfPro is offline
LawnSite Member
 
Join Date: Sep 2002
Location: zone 7/8
Posts: 232
Problems with new design trimmer head

I thought I'd give Oregon some real world feed back on the new design trimmer head that works with the "Flexi- Blade" line.

The head is built out of quality materials, (aluminium)but it needs improvements in the line holding fixture. I have the old style "Quickloader" head and have had zero problems with it.

The new style one that costs $40.00 locks up each time i use it.
Very dissapionting.

What it does is lock the line so that it cannot be removed with out taking the whole assembly apart each time you change line.... not good at all.
Any suggestions Oregon? Thanks

BTW: The Flexiblade line works well.
  #2  
Old 06-21-2004, 09:47 AM
Oregon Tech Oregon Tech is offline
Sponsor
 
Join Date: Aug 2003
Location: Kansas City Missouri
Posts: 58
I am sorry to hear that you are not having a good experience with this product. I suggest that you take it back to the dealer you bought it from. Then ask them to get it back to me through the proper channels. I have not heard of this problem before. Hopefully another head will solve this problem for you.

Glad to hear that you like the line. Also thanks for the heads up with this. I will look for your head coming back to me so we can see what the problem is.

Thanks
  #3  
Old 07-29-2004, 12:58 AM
Shady Brook's Avatar
Shady Brook Shady Brook is offline
LawnSite Bronze Member
 
Join Date: Aug 2001
Location: Indiana
Posts: 1,517
I just purchased one of these heads as well, and experience lock up each time I try to remove the line. Have you folks come up with anything new to rectify this problem?

Thanks
Jay
  #4  
Old 07-29-2004, 09:53 AM
Oregon Tech Oregon Tech is offline
Sponsor
 
Join Date: Aug 2003
Location: Kansas City Missouri
Posts: 58
Jay,

I am very sorry to hear that you are having a bad experience with our product. I realy need to get one of these heads that has the line locked in place back to me. If you will send me a private e-mail with your name and address I will send you another head. If you can get yours to lock up please trade it with the one I will send you and get the other back to me. We will get the problem resolved as soon as we have it identified.

Thanks again for the input. I will look forward to getting your e-mail. Send it to jeff.martin@oregonoep.com.

Thanks
  #5  
Old 08-09-2004, 11:42 PM
Shady Brook's Avatar
Shady Brook Shady Brook is offline
LawnSite Bronze Member
 
Join Date: Aug 2001
Location: Indiana
Posts: 1,517
No Response

Jeff

I have sent some e-mails, and a PM with no response. Are you having problems with your e-mail? I want to know if you sent out a head last Friday as you indicated you would. I have removed the head from the trimmer, it is too frustrating in it's present state to continue to use. Please let me know the status of the head. Also the design on the bottom cover cap seems to be lacking in my opinion. The plastic piece does not seem to lock well and falls off and vanishes far to easy.

Thanks
Jay
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.com™ - Moose River Media
All times are GMT -4. The time now is 08:35 PM.

Page generated in 0.07555 seconds with 9 queries