07 Super Z 26 kawasaki LC

Discussion in 'Hustler Turf Equip (Archived)' started by Rangr25, Apr 20, 2007.

  1. Rangr25

    Rangr25 LawnSite Member
    Posts: 44

    I just bought this mower a few weeks ago and have only used it a couple times so im not real formiliar with everything yet.... but after i mowed today and i ideled down the engine the oil light came on and it started buzzing at me... according the the manual that only occurs when there is something wrong with the oil pressure.. is this actually the problem or is there something else going on that im not aware of?
    hope to hear some input... thanks!
     
  2. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,760

    Hmmm......
    It could be low on oil after or during the break in period.
    Have you called your dealer and let them know?
    Check the oil before starting the engine again, add oil if needed.
    Regardless, please call the dealer to let them know what is happening.

    Pj
     
  3. TLS

    TLS LawnSite Fanatic
    Posts: 7,940

    My demo SuperZ 66" 26hp LC Kawi did the same exact thing.

    I think the sending unit for the idiot light might be a bit sensitive.
     
  4. Rangr25

    Rangr25 LawnSite Member
    Posts: 44

    just took the mower to the shop and they are also thinking its the oil sending unit so hopefully they can get it all fixed up!
     
  5. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,760


    Good, let us know how you make out.

    Pj
     
  6. MJB

    MJB LawnSite Silver Member
    from Wa
    Posts: 2,869

    My demo last year did it to until about 20 hrs then it seemed to stop. But I didn't buy that one because of it.
     
  7. Rangr25

    Rangr25 LawnSite Member
    Posts: 44

    the dealer claims they fixed it but it also seems as if they raised the idle RPMs for it so it wont get the low oil pressure now.... i dont know if that is the right thing to do or not but it seems to be ok for now....
     
  8. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,760

    Was the idle RPM out of spec? did they say?
     
  9. Rangr25

    Rangr25 LawnSite Member
    Posts: 44

    nope they didnt even mention that they turned it down but its pretty different... doesnt really idle down much after have throttle if any
     
  10. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,760

    Keep a eye on the light and let the dealer know if it shows up again.
    I am thinking after some hours the unit will be broken in comfortably and this will be a non issue.

    Pj
     

Share This Page