1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

15HP Kawasaki Troubles Please Help!

Discussion in 'Mechanic and Repair' started by Lawn Dog2001, May 20, 2003.

  1. Lawn Dog2001

    Lawn Dog2001 LawnSite Bronze Member
    Posts: 1,027

    Im having some engine troubles and I was hoping someone can help me.

    My 15HP Kawasaki engine is running real rich. It is giving off a bad fuel smell from the exhast. The engine is blackening oil almost instantly. I just changed the oil and filter yesterday, and after today the oil is already black as tar. The engine is puffing black smoke, and just dosent sound right. It is running, and it is servicable, but obviously there is something wrong. It is also sucking gas alot faster than normal. I adjusted the throttle and choke tonight but that didnt help. I cant find any carb adjustments. There is an adjustment below the throttle adjustment. It looks like an idle adjustment but it is not listed in the manual. Im not sure what it does as no matter how I turned it it did not seem to affect the engine.

    If anyone has any advice please let me know. I would like to fix this myself as right now I can not afford to be without it.
  2. Hud

    Hud LawnSite Member
    Posts: 63

    Based on your description, it sounds like you've got uncontrolled gas flowing out of the carb into the cylinder. If it's as much as you describe, I wouldn't continue running it like that. Can't be good for it.

    I don't have a 15 hp Kaw, but if it has a float, needle, & seat like my FC420V has, that's where I'd check first. Leaking float, worn out needle and/or seat, dirt or something holding the needle off the seat.

Share This Page