17 Horse Kawi problems

Discussion in 'Lawn Mowing' started by BufalinoLand, Jan 22, 2011.

  1. BufalinoLand

    BufalinoLand LawnSite Senior Member
    Posts: 400

    Im having mega problems with 2 Kawasaki engines both 17 horse bought em new have 2 seasons on em less than a thousand hours. they are not running correct under load. is anyone experiencing this problem. the valves are out too i think. WTF. i cant buy new engines every 2 years. they are on scag walk behind hydros

    thanks
     
  2. BadRancher

    BadRancher LawnSite Fanatic
    Posts: 5,887

    Mine was doing that. It ended up being the coil.
    Posted via Mobile Device
     
  3. Skyking

    Skyking LawnSite Member
    Posts: 216

    What are they doing or nto doing??
     
  4. BufalinoLand

    BufalinoLand LawnSite Senior Member
    Posts: 400

    the engines will start hard, like 5 to 10 pulls sometimes and not idle or run right. at the end of the season the engines were bogging out
     
  5. Skyking

    Skyking LawnSite Member
    Posts: 216

    Check your fuel filters?
     
  6. BadRancher

    BadRancher LawnSite Fanatic
    Posts: 5,887

    Air filter also. Mine would seem like it was running right, then sound like it was missing, then sound like it was running right again and then would bog in grass. I changed fuel filter, air filter, then finally it got real bad. Sent it in to the shop and it was the coil.

    If you are sure it is not the coil, it has to be a fuel, or fuel delivery problem.
     
  7. BufalinoLand

    BufalinoLand LawnSite Senior Member
    Posts: 400

    bad ranch, ive changed the air filters like a maniac, like once a week, how much is a coil anyway
     
  8. BadRancher

    BadRancher LawnSite Fanatic
    Posts: 5,887

    Not too sure. Mine was covered under warranty. Where did you buy the motors? You maybe able to check http://www.smallenginewarehouse.com Someone passed this site on to me a lil while ago.
     
  9. sedge

    sedge LawnSite Fanatic
    Posts: 32,624

    If I could, I would never buy another kawi on my life. Nothing but problems. Head gaskets, oil leaks, valves, air cleaner sealing off, etc, so on and so fourth. They know me by name at warranty center and don't take my calls any more. Or at least the guy that looks at the problem and makes the decision won't talk to me any more.

    I'll take a long life briggs over a kawi any day.
     
  10. LushGreenLawn

    LushGreenLawn LawnSite Silver Member
    Posts: 2,123

    Mine did the same thing, I hate chasing problems so I took it to my dealer, they had it fixed for under $100. In my case they adjusted something in the governor. You also might need to clean your carb out, that fixed that problem with one of my snowblowers. Mine was a 19hp kawi on a John Deere.
     

Share This Page