17hp kawasaki not starting

Discussion in 'Mechanic and Repair' started by Jcs Lawn and Landscape, Feb 24, 2006.

  1. Jcs Lawn and Landscape

    Jcs Lawn and Landscape LawnSite Member
    Posts: 117

    i am having lots of problems now with my kawasaki motor. It ran perfect 3 weeks ago then i took the deck off of it to paint. Now i go to start it back up and nothing. So i figure the batteries dead but the charger says it has power. When i hook the charger up to it now only the starter turns but does not turn over the motor. And when it does want to turn it over it turns it a quarter of inch and you hear grinding. But when i turn it with my hand it turns fine but i get a loud backfire after a couple of turns. I need help on this asap. Lucky im buying a new ztr in a couple of weeks but i still need this walkbehind for hillls:dizzy:
     
  2. Jcs Lawn and Landscape

    Jcs Lawn and Landscape LawnSite Member
    Posts: 117

    i fixed it guys
     
  3. lawnmaniac883

    lawnmaniac883 LawnSite Silver Member
    Posts: 2,613

    What was wrong?
     
  4. Jcs Lawn and Landscape

    Jcs Lawn and Landscape LawnSite Member
    Posts: 117

    not a good connection of the terminals i was rushing to much
     
  5. TURF DOCTOR

    TURF DOCTOR LawnSite Silver Member
    Posts: 2,138

    WHOO RAHH Lesson learned
     
  6. J&R Landscaping

    J&R Landscaping LawnSite Fanatic
    Posts: 5,096

    Always something stupid and easy...most of the time anyway.....
     

Share This Page