19 HP Kawasaki sputters

Discussion in 'Mechanic and Repair' started by WJC, Aug 3, 2010.

  1. WJC

    WJC LawnSite Senior Member
    Posts: 364

    I have an FH580V 19 HP Kawasaki with 550 hours on it and it sputters when you put a load on the engine. Only does it when its hot. I've kept up with the valves adjustment since new. I've only run synthetic oil in it. Keep the filter clean. New plugs. New fuel filter.I tightened up the air gap on the coils to .012" from .014 to see if that would help, but had no effect.. Engine does not burn oil. Starts and runs fine for about 30 mins. then starts to sputter under a load.
    If anyone has had this problem and can shed some light on it, I would appreciate it.
     
  2. laman

    laman LawnSite Senior Member
    Posts: 335

    Sounds like a coil is acting up. Sounds like a coil is acting up. Find restorob older post and you will find the instuctions on how to do it.
     
  3. WJC

    WJC LawnSite Senior Member
    Posts: 364

    Thanks for your advice, I'll look at some older posts
     
  4. topsites

    topsites LawnSite Fanatic
    Posts: 21,654

    I second the ignition coil diagnosis.
     
  5. WJC

    WJC LawnSite Senior Member
    Posts: 364

    I appreciate the advice. I have a 13 hp kawi twin, and I'm gonna see if it has the same part # coils on it. If it does, I'll swap them out to see if it corrects the problem. Thanks again
     
  6. A Leaf Above

    A Leaf Above LawnSite Member
    Posts: 223

    Also check the little rubber hose that runs from fuel pump to top of valve cover...If it doesnt make a good fit it will cause motor to sputter also ..
     
  7. WJC

    WJC LawnSite Senior Member
    Posts: 364

    That little hose appears to be ok.
     
  8. laman

    laman LawnSite Senior Member
    Posts: 335

    Have you checked coils yet?
     
  9. WJC

    WJC LawnSite Senior Member
    Posts: 364

    I looked through older restrorob posts and could not find any that described how to check coil resistance. I checked the coils on my 13 hp kawi, but one of those is a different part # than the other, my 19 hp engine has identical part # for both coils. I was going to swap them to see if it fixed it. I might just try it anyway if I cant find a resistance check.
     
  10. BigFish

    BigFish LawnSite Gold Member
    Posts: 3,157

Share This Page