20 hp kohler walker starting trouble

Discussion in 'Mechanic and Repair' started by buzzer12, May 28, 2007.

  1. buzzer12

    buzzer12 LawnSite Member
    Posts: 10

    i recently put new rings in this engine, new gaskets . benched tested it before i put it back in my walker. the engine starts perfectly . the trouble is that when i put it back in the machine it won,t start. it wants to but it wont. i put new plugs and there is spark the compression is 65 :confused: on both sides. still won,t start???? i take the engine out to the bench she starts right up!!!!!! i even disconnected the safety switches while it was in the machine that didn,t work. is the machine grounding out some where? please does anyone have any ideas , i.m going craze!!!!!!!!!!!!!!!!!!!!!!
     
  2. lucforce

    lucforce LawnSite Member
    Posts: 223

    turn the fuel valve back on
     
  3. Bill Kapaun

    Bill Kapaun LawnSite Senior Member
    Posts: 915

    Actually, lucforce might be on the right track. What happens if you prime the carb with a dribble of gas?
    Is there gas TO the carb?
     
  4. buzzer12

    buzzer12 LawnSite Member
    Posts: 10

    when the engine is in the machine and the gas is on, the gas spits up and out of the carb, when i disconnect the gas and let the garb go dry and then dribble gas in the carg it sill wont start!! but the second i unhook everything and take the engine out of the machine dribble gas in the carb it starts up and runs every time ???????????????????????
     
  5. lucforce

    lucforce LawnSite Member
    Posts: 223

    You have a safety switch issue or a short. Pull a spark plug wire and verify whether or not you have spark. I venture to say that you do not.
     

Share This Page