1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

2001 C3500HD Issue

Discussion in 'Trucks and Trailers' started by White Gardens, Oct 2, 2011.

  1. White Gardens

    White Gardens LawnSite Fanatic
    Posts: 6,783

    Trying to figure out a gremlin that is causing me fits.

    My C3500HD, with an 8.1 gasser has been doing a funny thing this past year.

    If I start the truck and let it idle for more than 5 minutes, it doesn't want to really go when I put it in drive.

    It acts like it's starved for fuel, or just not firing right.

    As soon as I pull over and shut the truck off for 30 seconds, I can start it back up and it drives fine.

    I'm getting no check-engine light, power loss light. We ran a full diagnoses and tests just last spring and it only showed that one cylinder had a miss-fire at idle. Since then I've done a tune-up with wires and plugs, but haven't run a diagnostic since then.

    Any thoughts before I run another diagnoses?

    Thanks.

    Nick
     
  2. BayouGator

    BayouGator LawnSite Member
    Posts: 8

    Sounds like you have trash in the fuel line, try changing the fuel filter.
     
  3. White Gardens

    White Gardens LawnSite Fanatic
    Posts: 6,783

    What has been replaced in the last 8 months.

    Fuel Filter.
    Fuel Pump
    Transfer Pump
    Rear Sending Unit
    Fuel Pressure Regulator

    The thing that gets me is that it does it only after I've let it idle for an extended period of time at cold start-up. Even then I can shut the truck off for 30 seconds and start it back up and it's fine.

    ..
     

Share This Page