2007 Mini Z PTO clutch intermittent issue

Discussion in 'Hustler Turf Equip (Archived)' started by pilotguy, Apr 13, 2013.

  1. pilotguy

    pilotguy LawnSite Member
    from Texas
    Posts: 2

    I have a 2007 Mini Z 19/52. I am having an intermittent issue with PTO switch. When I pulled the Deck Clutch switch the PTO cluth will initially engage and the blades will turn. The issue is it will then stop after 30 sec. When I then tried to pull the deck clutch switch and to engage the blades again it did nothing. When I leave the deck clutch switch on I can hear the the clicking sound and I can see the blades tried to engage and then stop. It would do it on and off like turning on and off a light switch. Can someone help? Thanks in advance...
     
  2. cboudet

    cboudet LawnSite Member
    from florida
    Posts: 16

    Sounds like you have a partly broken wire or bad contact somewhere.
    I would check and clean all the contacts of the connector plugs first to see if that is it.
    I am in worse shape than you.
    I don't get voltage at the clutch and I am having a hard time trying to trace the wires.
    I tried posting last night, but it has not been approved and posted yet.
     
  3. hustler1

    hustler1 LawnSite Member
    Posts: 77

    What was your final solution? I have even replaced my clutch and pto switch and nothing happens when I pull the switch on a super mini z 52".
     
  4. catfish1954

    catfish1954 LawnSite Member
    Posts: 22

    check the pig tail wire there is blackbox between the seat and the motor some times they shake loose. one of the wires go's to switch and other one goes to PTO clutch !!!!
     

Share This Page