1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

2010 bad boy outlaw left hydro problem

Discussion in 'Mechanic and Repair' started by wilson1, Jul 10, 2012.

  1. wilson1

    wilson1 LawnSite Member
    Posts: 2

    Hi I was just wondering if anybody else was having problems with the 2010 outlaw hydros? I bought mine when they first came out and has been doing well but started feeling weak on left side after mowing for awile. I have changed filters and oil and replaced belt but it is still weaker then the right side. I see retrodog is knowlegable on them it only has 300 hrs on it wondering if they have had problems because i see they changed the whole hydro setup on the 11s and 12s. I have been running toro zs and Hustlers zs in the past and can say so far the badboy has held its own just hoping they will stand behind it if it is a hydro problem.
     
  2. retrodog

    retrodog LawnSite Silver Member
    Posts: 2,420

    As far as i know the 5400's have not been touched yet for repair. Its usually a belt tension problem everytime when the left is not as responsive. The hydros have a 2 year warranty, so you need to get checked out before warranty goes out....
    Posted via Mobile Device
     
  3. wilson1

    wilson1 LawnSite Member
    Posts: 2

    Ok thanks for the reply will get it back to the dealer and see what the come up with was just seeing if anyone else has had any trouble.
     
  4. retrodog

    retrodog LawnSite Silver Member
    Posts: 2,420

    The outlaw and extreme still have same tranny as 2010, xp only reason it went back to the parkers is that there wasnt enough room for the 54's with the suspension setup as they are huge... check belt good on tension before your trip...
    Posted via Mobile Device
     

Share This Page