2011 GMC HD problem??

Discussion in 'Trucks and Trailers' started by meets1, Apr 16, 2011.

  1. meets1

    meets1 LawnSite Gold Member
    Posts: 3,757

    Driving today with no problems. Went to unhook trailer and truck would not start. 7700 miles. Had power but nothing when I turned the key. Code came across saying the 4 wheel drive systems needs service.

    I called dealer - spoke to mechanic - he told me to jump the truck or disconnect battery for a minute or so and then re-connect - saying its reboots the computer

    Well I got it started, let it run for a while - I needed to load trailer. I took off slow around the corner then pulled onto the hiway. Needless to say I had no power - all my gauges went to the off position - like when you shut your truck off, and basically was in idle and limped back to the shop which took about 15 minutes by the time I managed to turn around and re-route myself.

    Anyone with an idea of problem? It won't start at all right now. There saying dealer will have to tow truck to there shop.
     
  2. Trucklover

    Trucklover LawnSite Member
    from MD
    Posts: 90


    Is your truck diesel or gas?
     
  3. meets1

    meets1 LawnSite Gold Member
    Posts: 3,757

    Sorry - Duramax
     
  4. Trucklover

    Trucklover LawnSite Member
    from MD
    Posts: 90

    I have the same truck, Try checking the Downpipe that would explain the lack of power and i know its a common problem with the 11s, Also check out Duramaxforum.com
     
  5. meets1

    meets1 LawnSite Gold Member
    Posts: 3,757

    downpipe - don't know? In the process of lookiing at the dmax forum
     
  6. Trucklover

    Trucklover LawnSite Member
    from MD
    Posts: 90

    The down pipe that bends coming down from the motor, there will be a clamp holding it in have someone start the truck and look at the clamp area and see if any smoke comes out
     
  7. bob

    bob LawnSite Platinum Member
    from DE
    Posts: 4,254

    Diesel exhaust fluid low?
     
  8. meets1

    meets1 LawnSite Gold Member
    Posts: 3,757

    No the fluid is fine. Just changed oil and added. Although I have had it low and I have been down to 35 mph - dealer never had to full to begin with!
     
  9. meets1

    meets1 LawnSite Gold Member
    Posts: 3,757

    Alright - main computer is out. Not telling truck what to do. If it happens during a trip - like me, it will shut the truck down to idle and you creep to where u need to go. Stop it, shut it off, that will be it. So therefore new computer coming and hopefully back in action by thursday.
     
  10. Turf Commando

    Turf Commando LawnSite Bronze Member
    Posts: 1,185

    GM quality control explains why they went bankrupt..
     

Share This Page