1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

20hp Kohler Command Idle Problem????

Discussion in 'Mechanic and Repair' started by milsaps118, May 26, 2007.

  1. milsaps118

    milsaps118 LawnSite Senior Member
    Posts: 559

    I have an '04 LAZER with a KOHLER COMMAND 20hp with about 600hrs on it. It has been running flawlessly until now. At full throttle it revs higher than usual, and when I pull the throttle back to idle it has almost little to no response at first then starts to idle really low then really high even when I don't adjust the throttle. Basically it revs high and low intermittently (fluctuates) on its own, and when I go to drive it I notice a huge power loss even at high RPM. Sometimes I can barely get going in forward and reverse.

    Has anyone experienced this before with a 20hp Kohler? I checked the throttle linkage and cable and everything seems to be fine.

    Any suggestions???????????????????
     
  2. milsaps118

    milsaps118 LawnSite Senior Member
    Posts: 559

    Bump........
     
  3. Jason Pallas

    Jason Pallas LawnSite Bronze Member
    Posts: 1,325

    Sounds like a return spring may be broken on the throttle linkage.
     
  4. milsaps118

    milsaps118 LawnSite Senior Member
    Posts: 559

    bump bump bump.......
     
  5. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    Spray all linkage and your cables with penetrating oil. Also spray the governor arm shaft coming out of the block making sure it moves freely. Dirt build-up can cause it to bind up.

    If this does not solve the problem then adjust the governor as below.


    [​IMG]
     

Share This Page