1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

26 EFI Kohler problems

Discussion in 'eXmark' started by TOOMUCHWALKING, Jun 11, 2007.


    TOOMUCHWALKING LawnSite Member
    Posts: 167

    Hi folks , need advice on my 2001 72" Lazer Z with the fuel injected kohler . For the last couple of weeks , it's been starting fine the first time , and then will not start to go back on the trailer after using the machines in front of it . I replaced the oxygen sensor , blasted the plugs ,it has spark and fuel , 150 PSI compression in both holes , 925 hours . Is there something easy that goes out to cause this ? If you crank it over until the battery's almost dead at full throttle , it might start . Using my battery booster pack starts it sometimes , but not today .

    TOOMUCHWALKING LawnSite Member
    Posts: 167

    Well , today the mechanic I use replaced the ignition switch , OPC relay , and blade clutch ( unrelated...I think ). Started up nice , ran about half throttle and cycled the blade clutch about six times , then shut it off . Crankcrankcrankcrankcrankcrank.....and on and on and...nothing . Mechanic now advises replacing the throttle position sensor . What else is left ? C'mon , somebody speak up !
  3. thecrankshaft

    thecrankshaft LawnSite Member
    Posts: 172

    Is the fuel pump turning on?

    TOOMUCHWALKING LawnSite Member
    Posts: 167

    Yes ; thanks for answering . It's been fixed--after replacing the oxygen sensor , the keyswitch and some relay near the keyswitch failed to fix it , my technician replaced the throttle position sensor and added a factory wiring upgrade , which added a couple of grounds to the computer and a new oil pressure sensor that requires soldering on a new connector . Works like new now !

Share This Page