27HP Kawasaki died suddenly while mowing

Discussion in 'Mechanic and Repair' started by rreyn1812, Aug 26, 2011.

  1. rreyn1812

    rreyn1812 LawnSite Senior Member
    Posts: 444

    I'm out in a field that is part of a cemetery just mowing away with my JD Ztrak 830 w/27hp Kawa and suddenly the engine just drops to an extremely low idle. I kill the blades and the engine is still just barely idling. Try moving the sticks forward hoping I can just get it back to the trailer, but no way. It dies. Getting a real sinking feeling and just hoping it's nothing too bad. Try to start it, and it does start, barely! Try getting it to move again, and it dies. NO! I just know this isn't going to be fun. :confused:

    I noticed that the throttle doesn't feel right, so I start checking the connections and everything looks pretty good, so start looking at everything just hoping I find something simple. Ah ha!! I noticed that the governor spring has broken at the bottom so I whip out the old Leatherman and put a turn in the bottom and reconnect it to the governor lever at the bottom of the motor. Holding my breath I give her a try. Starts right up and is running good; maybe just a tad fast, but still good. Whew!!! Dodged a bullet on this one!! :clapping:

    The dealer has to order the spring, but it will be in tomorrow so I won't miss any mowing. Engine has approx 535 hrs on it and other than this problem is running good on Mobil 1. :cool2:
     
  2. Firefighter337

    Firefighter337 LawnSite Senior Member
    Posts: 373

    The suspense was killing me. Glad it worked out for you.
     

Share This Page