30+ pulls to cold start Redmax 7500! Anyone else have this problem?

Discussion in 'Mechanic and Repair' started by iforgotmybackpack, Dec 3, 2013.

  1. iforgotmybackpack

    iforgotmybackpack LawnSite Member
    Posts: 41

    Like the title says, I have 2 7500 blowers. One is used more than the other. The most used one can take between 30-50 pulls before it fires for the first start of the day. Summer cold starts in the morning require around 15 pulls and currently at 35 degrees in the morning it takes closer to the 50 pulls. Once it warms up it will start with one pull. Air filter is new and so is plug. Primed 5-7 pumps and choke is on. Carb problem? Thanks in advance for any help.
    Posted via Mobile Device
  2. Jason Simmons

    Jason Simmons LawnSite Member
    Posts: 231

    Had the same problem, choke it and prime it 8-13 times then pull, should work
  3. echo

    echo LawnSite Bronze Member
    Posts: 1,695

    I only choke both the 580 and 570. No priming of the bulb but the 580's get used all the time. Unless they sit I never prime them. No matter how cold it takes 3-4 pulls on first start up. I always have throttle set halfway.
    Posted via Mobile Device
  4. Vecchio Lawn Care

    Vecchio Lawn Care LawnSite Senior Member
    Posts: 905

    Adjust your valves
  5. Breezmeister

    Breezmeister LawnSite Bronze Member
    Male, from South Jersey
    Posts: 1,547

    I don't know what Redmax's manual says to do for cold starts. But our guys will bring any unit (we only use Tanaka) back to me if it dosen't start
    with in 10 pulls. This is the way I showed our guys to start them. Prime it untill you see fuel going back in to the tank in the return line, full choke
    and Full throttle. Most of the time they will start on the first or second pull, some times 3 or more if it's a older unit.

    If you do it this way and you still have to pull it alot, then you have a problem some where......
    ericg likes this.
  6. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    If ANY machine doesn't pop-spit or sputter with-in 4-5 pulls it's time to quit and find out why, Not continue pull'n...... All your do'n is wearing your arm and recoil assembly out.....
  7. Sharpcut 1

    Sharpcut 1 LawnSite Senior Member
    Posts: 450

    Breezmister hit the nail on the head. Half throttle or above first cold start of day, will fire within 3 pulls, if you leave it at idle, you'll yank your arm off.
  8. MRCo.

    MRCo. LawnSite Member
    Posts: 227

    Errr....these machines are two cycle.

    I here have Tull one more than twice. Cheap action: new fuel filter and treat with Mechanic in a Bottle.
  9. agent walker

    agent walker LawnSite Senior Member
    Posts: 461

    Clean carb. No way should they be that hard to start.
  10. sjessen

    sjessen LawnSite Gold Member
    Male, from Knoxville, Tn
    Posts: 3,346

    Had 2 8500's with the exact same issue. Replaced all kinds of parts with no improvement. They were like this from day 1.
    ericg likes this.

Share This Page