48" ferris problem

Discussion in 'Lawn Mowing' started by QuadRacer041, May 26, 2004.

  1. QuadRacer041

    QuadRacer041 LawnSite Senior Member
    Posts: 365

    i have a 48" dual drive hydro ferris with a 14hp kawi engine. ive owned since it was new, about 6 years now. ive started to notice that it doesnt cut as smooth as it used to. now with the spring here i notice it even more.
    the blades are kept sharp, ive even installed new blades, tighten all the belts and still same result. it bends the grass over and doesnt have a smooth nice cut.
    what could it be????
    is it possible that the engine is just getting tired??????
    if thats what it is ill replace it cause the machine is in mint condition.
     
  2. rodfather

    rodfather LawnSite Fanatic
    Posts: 9,501

    Could be the motor, check the rpm's. If you do replace it, don't go with anything less than 17 horse...14 is way too little IMO.
     
  3. QuadRacer041

    QuadRacer041 LawnSite Senior Member
    Posts: 365


    yes i agree, will a 17 fit on there though
     
  4. mpblass

    mpblass LawnSite Member
    Posts: 37

    I had a similar problem with one of my Snapper wb's when one of the spindles needed rebuilt. Have you had them checked out?
     
  5. QuadRacer041

    QuadRacer041 LawnSite Senior Member
    Posts: 365


    well they are not as tight as new but they aren't bad, they have some play in them.
    but its not a smooth cut all the way across not just one side, or spindle.
     

Share This Page