9 HP briggs won't stay running

Discussion in 'Mechanic and Repair' started by steveair, Aug 9, 2001.

  1. steveair

    steveair LawnSite Bronze Member
    Posts: 1,073

    hello,

    I just picked up a coleman generator with a 9hp B&S vanguard and want to know if you may have any advice.

    The engine starts right up, runs fine for about 2 minutes, then just dies. If you play with the choke a little, you can keep it running for a while, but eventually it dies and then will not start at all.

    I think its a fuel problem of some sort, but not sure what. It had a brand new carb put on last year, ran excellent for a while, but then had the same problem again.

    Also, it appears gas slowly drips somewhere out of the carb, but not sure where.

    I got the generator for free, so just want to see if I can't fix it up and get some use out of it.

    I know one of the problems is that it sits for a long time between uses, and I'm sure the carb is mucked up again.

    Any advice appreciated.

    steveair
     
  2. Fish

    Fish LawnSite Member
    Posts: 139

    One quick thing to check is the valve clearances and the rocker
    arm studs for looseness. I have seen problems with Vanguards
    in this area.
    Fish
     
  3. SMB

    SMB LawnSite Senior Member
    Posts: 323

    Check all gas filters, the gas cap, clean the carb, and put in a rebuild kit. This should fix it--for less than $20. Also, be sure there isn't any gas in the crankcase from the needle not seating well, we ruined an engine this way!
     
  4. SMB

    SMB LawnSite Senior Member
    Posts: 323

    Also check the shrouding for rats' nests, they can cause your engine to overheat, yep, had that happen too!
     
  5. Robert Doubrava

    Robert Doubrava LawnSite Senior Member
    Posts: 342

    you might want to check the fuel line for cracks or holes.
     

Share This Page