97 Ranger Battery/Charging System Light came on...

Discussion in 'Trucks and Trailers' started by bdoss123, Aug 27, 2006.

  1. bdoss123

    bdoss123 LawnSite Member
    Posts: 131

    So last week I broke down on the side of the road in the Ranger 4 banger. Figured out that a loose connection on the negative battery post had caused the connector to short/fail. Replaced connector, charged battery, truck starts and runs fine.

    The thing is, the battery(or charging system) indicator has been on ever since I broke down. I am guessing that either the battery has been drained so much that it's toast, or the alternator is failing on me.

    Can anyone point me in the right direction?

    BD
     
  2. FearThisDeere

    FearThisDeere LawnSite Bronze Member
    Posts: 1,168

    I would say that you drained the battery passed any return. I di that to three batteries. Now, what caused the batter to draig? I would say that the alternator is gone. I went through 2 batteries in the span of a month. The kept draining until they were fried. I put a new alternator and another battery in and the truck ran fine (when I sold it a month later lol!). Luckily the origional battery was under warranty, so I only ended up buying one of the three batteries. I would start by going to a local Sears and have them check it. If it is dead, replace the battery and alternator just to be safe. It is a cheap preventative fix and you can do it yourself. Buy the battery from sears becuase you get a three year warranty. It has worked in my favor many times now!
     
  3. bdoss123

    bdoss123 LawnSite Member
    Posts: 131

    Thanks for the info. I'll prolly do the alt and battery, as the truck's got 110K on it.

    - BD
     
  4. FearThisDeere

    FearThisDeere LawnSite Bronze Member
    Posts: 1,168

    I would say that it is time for them!
     

Share This Page