1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

air in the hydro system

Discussion in 'Mechanic and Repair' started by Shady Brook, Feb 14, 2002.

  1. Shady Brook

    Shady Brook LawnSite Bronze Member
    from Indiana
    Posts: 1,517

    I just changed my hydro fluid, and filter in my Turf Tiger. I think I have air in the system, as when I engage the levers, it seems to bog down, and take longer to get to full speed. Does this sound reasonable? Also, how should I purge the system? Also, this is a drive shaft driven mower deck, and now for some reason the engine will die when I engage the blades. Does this sound like something that could be related to the hydro? I can not see how, but who knows.

    Thanks fellas
    Jay
     
  2. General Grounds

    General Grounds LawnSite Senior Member
    Posts: 902

    :blob3: shady did you fill the oil filter first until it would'nt take no more oil? and are you useing the proper weight oil in the drive system. as far as the engine dyin when you engage the blades you could have something restrict the blades from funtioning, how about the gear box oil have you checked that for seized bearing? Tony
     
  3. Shady Brook

    Shady Brook LawnSite Bronze Member
    from Indiana
    Posts: 1,517

    I just discovered what the deal was..... I changed the spark plug, but did not reconnect the plug wire! My question is.... How did it run at all? :confused:

    But she is running super now, does not appear to be an air problem. I do hate getting that hydro filter just tight enough, it always wants to leak some fluid.

    But then again, I must be ********. I don't mind, long is the machine is going.

    But just for kicks, how do you purge that hydro system?

    Thanks
    Jay
     
  4. General Grounds

    General Grounds LawnSite Senior Member
    Posts: 902

    :blob3: shady, a 2 cylinder engine will run with i cylinder, just not well and have no power, it will even sound weak, this is how we check if a cylinder has gone bad, you would puull the plug boot off and if the engine is still running then you know the side connected is good, if you where to pull the boot off and the engine where to shut down then you would know you have a down cylinder. as far as the hydro sytem goes i usually just drain the resiovoir and change the filter and dont mess with getting the oil out of the system, there are to many places for mistakes then. Tony
     
  5. Shady Brook

    Shady Brook LawnSite Bronze Member
    from Indiana
    Posts: 1,517

    Thanks alot General Grounds, that is very helpful. One thing that did cross my mind was, where is the second plug. I mean with two cyliders, you would think there would be two plugs. Oh well, there I go thinking again.

    Thanks
    Jay
     
  6. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    Try operating both levers forward and reverse about 1/2 inch about 100 times. Then recheck the fluid level. This should purge some of the air. Your other plug is symetrically across from your known plug. Can't miss it.
     
  7. Shady Brook

    Shady Brook LawnSite Bronze Member
    from Indiana
    Posts: 1,517

    khouse

    Shows you how observant I am!:rolleyes:

    Thanks for your help.

    Oh, one final question. If your filter continues to seap a bit, is it ususally because it is on too tight, or too loose?

    Thanks
    Jay
     
  8. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    If you have problems with that filter sealing then you probably have a scratch or machine error on the surface where the filter seats to the housing. The filter is on the low side of the hydro's so it onlt need to be tightened maybe 1/3 to 1/2 turn past of when the seal makes contact with the flange. Do you always have problems with this filter sealing?
     
  9. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    Maybe it's leaking from the filter housing gasket not the filter seal?
     
  10. Shady Brook

    Shady Brook LawnSite Bronze Member
    from Indiana
    Posts: 1,517

    So far every time I have changed the filter I get a leak. After jimmying around with it I can get her to stop. Has taken several attempts each time to get it right. I think I maybe going closer to a full turn. My problem is seeing when I initially make contact with the seal. I may have to back it off a bit.

    Thanks a bunch
    Jay
     

Share This Page