Another "I will never buy Echo again" thread

Discussion in 'Lawn Mowing' started by pjslawncare/landscap, Apr 23, 2004.

  1. pjslawncare/landscap

    pjslawncare/landscap LawnSite Bronze Member
    Posts: 1,410

    Got to a trim & mulch job today, whipped out my 3 year old Echo hedge trimmer and pulled, pulled, pulled & pulled. Not even a sputter. Third time past season they refused to start. Tired of messin with the darn thing. Its Shin or Stihl from now on!
  2. Petr51488

    Petr51488 LawnSite Silver Member
    from NJ
    Posts: 2,372

    Go with Stihl. They are the best. I have a Br420C Blower, and it it unbeleviable!
  3. lawnwizards

    lawnwizards LawnSite Silver Member
    Posts: 2,434

    maybe youre experiencing and ID10T error... in computer lingo.....
  4. jajwrigh

    jajwrigh LawnSite Bronze Member
    Male, from Martinsville, IN
    Posts: 1,405

    Nice one lawnwizard...
  5. pjslawncare/landscap

    pjslawncare/landscap LawnSite Bronze Member
    Posts: 1,410

    Whatcha talking bout willis!
  6. PaulJ

    PaulJ LawnSite Bronze Member
    Posts: 1,776

    My echo hedge trimmer gets used very little. It will sit for a month , but when I need it It fires right up in 2 or 3 pulls.
    Just bought an other echo trimmer. (almost bought shindaws but the echo dealer is closer and I had a credit there from something9ing else)
    NO complaints with echo after running them for a few years now.
  7. sawman65

    sawman65 LawnSite Senior Member
    Posts: 751

    welcome to STIHL COUNTRY we dont care what you used before
    just want to give you the best handheld power equipment out there.
  8. Teff's Lawn & Snow

    Teff's Lawn & Snow LawnSite Member
    Posts: 53

    Sthihl is a great choice, great equipment, parts availability, and customer service for there products. We have used echo good equipment but was always touchy starting.
  9. LwnmwrMan22

    LwnmwrMan22 LawnSite Platinum Member
    Posts: 4,372

    Never had a problem with my Echo stuff, 16 years now. Maybe cause I run a lean mixture of Amzoil?
  10. BobR

    BobR LawnSite Senior Member
    Posts: 714

    Have you done the obvious - fresh gas, new plug and clean the air filter ?? Are you getting 'spark' at the plug ?? You indicated your machine is 3 years old, mine was about that when it would no longer run over an idle and started real hard problem was a plugged 'spark arrestor' in the muffler, a friend suggested tossing the arrestor (did it) and haven't had a problem since, in fact it runs better than new.


Share This Page