1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

anyone with same problem

Discussion in 'Landscape Architecture and Design' started by gobblet, Feb 27, 2007.

  1. gobblet

    gobblet LawnSite Member
    Posts: 155

    Bought Scag tiger cub in late 06 nothing but trouble. Within first month hydro pump went (taken to dealer fixed). When temps got cold would not start taken to dealer said it was fixed. Once again would not start in cold, dropped off at dealer at the end of the season. January stopped at dealer and said it needs a stronger battery but could not find one. Two days ago stopped at dealer and said it is the starter. Has anyone had a similar problem with Scag or anyother machine that just seems to be a lemon. Please suggest what I should do next.
  2. Piscitelli Landscape

    Piscitelli Landscape LawnSite Member
    Posts: 51

    I Bought a 06 turf tiger and tiger cub they have both been great they both have trouble starting in the cold but it depends how cold and how long they have been sitting where i live it has been 10 degrees at times and they sat for a month and then i had trouble starting them but the one day it went up to 35 degrees for a few hours they started on a dime. might just be how the dealer put it together or luck of the draw. but i wouldnt throw scag to the wolves because of one mower i have been more than satisfieid with my mowers
  3. LB1234

    LB1234 LawnSite Gold Member
    Posts: 3,210

    No major recurring problems with our TT or WB's. Had one issue with WB hydro pumped (After two years) and was fixed. Had problem with Z with stator (sp?) and was fixed under warranty. Other than that luv em and highly recommend them.

    MOW PRO LAWN SERVICE LawnSite Bronze Member
    Posts: 1,566

    ZERO problems on mine had a oil leak on a new wildcat fixed no problem.

Share This Page