B&S INTEK 10 hp on Little Wonder blowers - FAIL!

Discussion in 'Mechanic and Repair' started by DaHapster, Oct 23, 2008.

  1. topsites

    topsites LawnSite Fanatic
    Posts: 21,654

    Well it isn't, technically the problem is with, in your case, LW.
    Why that is so, LW put the engine on THEIR machine.
    I don't care who made it, if a manufacturer of a machine puts an
    engine from another company on THEIR machine, it is THEIR problem.

    Yes...
    If I decide to build cars but am short on resources,
    so I decide to drop Ford engines in them, sell them like that.
    And for some reason my customers decide the Ford engines have problems.
    It's MY Problem, not Fords!

    I am the one who decided to put Ford engines in there.
    If I want the problem fixed, I have to deal with it.
    Now I might order Chevy engines in the future,
    but until I stop putting Ford engines in my cars,
    and so long these Ford engines give my customers headaches,
    since I built the car and I ordered the engines, it's my problem.

    Simple.

    That's the kind of thing really gets me going.
    Damn.

    Out of this world, way out there, really.
    Maybe they should write Briggs on their blowers then?

    btw...
    I am sorry you had to deal with that.
     
  2. DaHapster

    DaHapster LawnSite Member
    Posts: 5

    No return call from Briggs yet, but that's OK. I don't expect any "goodwill" help from them.

    I now have over half of my blower "fleet" in the shop, all purchased from 2004 - 2005 and ALL with either siezed exhaust valve, popped seat and/or bent pushrods. The overheating is quite localized around the exhaust port.

    In every one of these machines the oil was changed less than 30 hours prior. I checked/reset the valve lash on all of them this past Sept. in preparation like every year.

    NONE of these machines were over speed. In fact, I "tweaked" 'em all down a bit. (approx 200 - 400 RPM).

    I am replacing them all with Honda GX390's.

    I'll never have another Briggs engine in this shop again.
     
  3. TempleLawnCare

    TempleLawnCare LawnSite Member
    Posts: 204

    I know this is an old thread. Did you ever replace with Honda GX390? Did it bolt right up? Thanks
     
  4. Darryl G

    Darryl G LawnSite Fanatic
    Posts: 8,033

    Funny I just found this thread too doing a search on the 10HP Briggs...guess we're not alone!
     

Share This Page