Back Pack Blower Problems

Discussion in 'Lawn Mowing' started by LightningLawns, Sep 28, 2005.

  1. LightningLawns

    LightningLawns LawnSite Senior Member
    Posts: 279

    My echo blower keeps fouling out the spark plug, what usually causes this to happen?
     
  2. LightningLawns

    LightningLawns LawnSite Senior Member
    Posts: 279

    I'm sure someone has had this problem and knows what usually causes this to happen. I could really use some advice on fixing this problem.
     
  3. HTL

    HTL LawnSite Member
    from AL
    Posts: 2

    is your gas mixture correct?
     
  4. brucec32

    brucec32 LawnSite Platinum Member
    Posts: 4,403

    too much oil in the gas mix?
     
  5. AtlYardWorks

    AtlYardWorks LawnSite Member
    Posts: 19

    Exactly what I was thinking.
     
  6. lawnmaniac883

    lawnmaniac883 LawnSite Silver Member
    Posts: 2,613

    Too much oil in mix, or carb is running rich, or your not running it at wot enough.
     
  7. BryPaulD

    BryPaulD LawnSite Senior Member
    from MI
    Posts: 392

    O.k. Now ya got me wondering. I didn't quite use up the last of my mix in a 5 gallon can. I added one of the lil thingys of oil for a 5gallon and only put in 4.3 gallons of gas. Will this affect anything?? Thanks
     
  8. Runner

    Runner LawnSite Fanatic
    Posts: 13,494

    I run 4 oz. to a gallon, and that's real rich. Another thing to consider, is make sure you took your spark arrestor screen out.
     
  9. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,326

    Which blower model are you talking about? I run a lot of units big/small and have not had the problem. I assume you are using Echo mix?
     
  10. grass_cuttin_fool

    grass_cuttin_fool LawnSite Gold Member
    Posts: 3,504

    Maybe a dirty or clogged air filter would be my thinking. Its making your mixture extra rich because its not getting enuff air?????
     

Share This Page