1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Bad advice from Lesco?

Discussion in 'Homeowner Assistance Forum' started by bderks, Jul 2, 2007.

  1. bderks

    bderks LawnSite Member
    Posts: 48

    I also posted this in the Lesco forum, but it doesn't seem to get many responses so I thought I would try here.

    The following is a situation I have with my one-acre long fescue lawn:

    On May 25th, I purchased the following from my local Lesco dealer in Grandview, Missouri:

    (3) bags of Momentum 21-0-11E Weed and Feed
    (2) bags of Dimension 0.10% 0-0-7M

    I applied both products that day as advised by the Lesco employee, using a Spyker spreader. The products worked as they are supposed to - lawn greened up nicely and controlled the weeds.

    On June 23nd I purchased and applied the following:

    (3) bags of Merit 0.2% 14-0-14 30% PPSCU

    I was worried about the fertilizer content of the Merit, since I had applied both the Momentum and Dimension only one month prior. I was assured by the Lesco employee that it would not be an issue. Merit was applied on the proper Spyker setting, and watered in over the course of the following 2 days.

    Fast forward to the 29th. During that Friday and Saturday, we received over 10 inches of rain. During that time I started to notice areas of my lawn where the grass blades were starting to discolor. Yesterday and today the lawn has dried out, and it's evident that spots have been severely burned.

    Does this look to be permanent damage which will need reseeding, or are the roots unharmed? I am not a professional - just a homeowner who takes pride in his lawn. I followed the instructions and advice from my local Lesco - did I receive bad advice?

    Pictures of the damage:


  2. Rtom45

    Rtom45 LawnSite Senior Member
    Posts: 456

    The damage appears to be a disease called red thread. It is not as a result of overfertilizing. Take a close look at the lawn in the morning when there is dew on the ground. If this is red thread you should see pink - red stringy things on the leaf blades. I don't think the Lesco rep gave you bad advice.
  3. carcrz

    carcrz LawnSite Silver Member
    Posts: 2,085

    I use the same supplier & haven't had any issues to date. I also make sure that I have the Lesco spreader callibrated correctly.
  4. bderks

    bderks LawnSite Member
    Posts: 48

    Thanks for the replies.

    There are no red threads in the morning, so I don't think that's what this is.

    carcrz - I used a Spyker spreader on the recommended setting printed on the Lesco bags. I'm fairly confident it was correct, since I used the lbs/1000 that it should have taken for one acre.

    My lawn was in perfect shape until this week. It really sucks to put this much time, money and effort into it to have this happen. :cry:
  5. Capemay Eagle

    Capemay Eagle LawnSite Bronze Member
    Posts: 1,750

    I am having the same problem. My lawn was beautiful up untill about two weeks ago. I cannot figure out what the problem is.
  6. carcrz

    carcrz LawnSite Silver Member
    Posts: 2,085

    You might just give Curtis or Darren a call then. I'm sure they will be more than happy to give you some help w/ a solution.
  7. Bill S

    Bill S LawnSite Member
    Posts: 184

    It could possibly be brown patch or rust... Best bet, take these pics to your LESCO distributor as they will be most familiar with your local regions "issues."

    I have dealt with several LESCO distribution centers and they have always been very helpful. Good luck!
  8. bderks

    bderks LawnSite Member
    Posts: 48

    Thank you Bill! I think you may be right about this being brown patch, all the characteristics match up.

    I was wondering how it could be anything other than over-fertilization since there is a defined line between my lawn and my neighbors, but it sounds like a high level of nitrogen can encourage the growth of brown patch. Thus it appeared after my last application.

    Hopefully I can do something about this!
  9. M.C.L.C.

    M.C.L.C. LawnSite Member
    Posts: 67

    This was definitely not caused by bad advice, or anything you did...well not intentionally anyways. Brown patch fungus is all over a lot of our lawns here in Wichita. What has happened is that with all the freakin rain we have had along with the off days of 80+ degrees with high humidity and last but not least our/your application of fertilizer containing nitrogen....thats the perfect scenario for fungus. Brown patch especially. They love nitrogen, we get a lot of calls saying "our yard has some spots that were missed when you fertilized", and they want more fert. i never give it to them it will just spread the fungus.:nono: Go back to your lesco guy and ask him what he can do for you regarding brown patch. Let us know how it goes!

    OH, and HAPPY 4th!!!!! :drinkup: :usflag: :drinkup:
  10. NattyLawn

    NattyLawn LawnSite Bronze Member
    Posts: 1,643

Share This Page