1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Bad start to a day...

Discussion in 'Lawn Mowing' started by LedgedaleLawn, Nov 21, 2009.

  1. LedgedaleLawn

    LedgedaleLawn LawnSite Senior Member
    Posts: 377

    So we get started early today doing leaf removals. We have about 2 dozen left and winter is coming fast. So I have 6 guys working today and a 5 job goal. Within the first 10 min all hell breaks loose, literally. Come to find out all the blades on the leaf loader were cracked and one had ripped away from the hub. The impeller was not even a year old, but we do use it heavily. So after about 2 hours and some welding it was back up and running. Needless to say we only got 3 jobs done.:cry:



    One of the jobs complete.

  2. LedgedaleLawn

    LedgedaleLawn LawnSite Senior Member
    Posts: 377

    Anyone else ever have this problem?
  3. Tharrell

    Tharrell LawnSite Silver Member
    Posts: 2,964

    What loader is that on and was the new impeller "new" or reconditioned before it let loose?
  4. LedgedaleLawn

    LedgedaleLawn LawnSite Senior Member
    Posts: 377

    It was on a 16hp Giant Vac. An as far as I know the impeller was new, if it was reconditioned I'm going to kick the dealers butt.
  5. G.M.Landscaping

    G.M.Landscaping LawnSite Senior Member
    Posts: 937

    I like the welding ball on your wedding ring. I remember those when I was married.:laugh:

    Hopefully my giant vac never does that.
  6. LedgedaleLawn

    LedgedaleLawn LawnSite Senior Member
    Posts: 377

    Ya, I hate when they do that. I guess thats what I get for not wearing gloves all the time.:laugh:

    TREEGUARD LawnSite Senior Member
    Posts: 303

    on my first day of clean ups this year we get to the first house start getting all the leaves out front go to cut the lawn and the blades will not engage on the stander no big deal i tell my worker to use one of the other machines for now. istart with the leaf loader & about 5 minutes in to the pile it shuts off.. i go over &take a look and thecarborater is on the ground both bolts broke off.. nice way to start
  8. gunsworth

    gunsworth LawnSite Member
    Posts: 81

    my dad had the same thing happen this year, my guess it that the house pictured is the culprit with all the rocks. upon inspecting his he had an area of the shroud worn down and a rock must have hit that area at the same time the impellar did and kaboom. good luck, those are a ***** to get on and off, need special tools and then then the insane cost of the impellar

    STIHL GUY LawnSite Fanatic
    from CT
    Posts: 5,225

    mine is fine but ill have to keep an eye on it now
  10. 2low4NH

    2low4NH LawnSite Bronze Member
    from NH
    Posts: 1,891

    my new billygoat impeller is crazy thick i wanna say its almost 3/8's my old one was starting to fold over on the edges.

Share This Page