Blades engage by themselves

Discussion in 'Great Dane' started by lawnman_scott, Jun 10, 2003.

  1. lawnman_scott

    lawnman_scott LawnSite Fanatic
    Posts: 7,547

    I have a 52 surfer, and the blades have been engaging by themselves off and on. Everything is tight, blets, bolts. Spindels, bearings, and pulleys are good. I checked all wires and fuses, and they are good. any ideas???????
     
  2. John Joensen

    John Joensen LawnSite Member
    Posts: 68

    Lawnman Scot:

    Please take the machine to a Great Dane dealer to be checked out. Sounds like a wiring issue or maybe a bad switch.

    JMJ
     
  3. Phishook

    Phishook LawnSite Bronze Member
    Posts: 1,143

    I've got a 1999 (I think) Charoit. Not a big deal, but I thought I'd mention it here.

    While the mower is running, I'm on the seat, the parking brake is on, and the PTO is on but disabled because of the parking brake. If you move one of the leavers (can't rember wich one), the blades will engage. They don't stay on, but it might be something to look into.
     
  4. John Joensen

    John Joensen LawnSite Member
    Posts: 68

    Phishook:

    Take your Chariot to any Great Dane dealer and I will cover the repair. We would like all the interloc switches to be in working order.

    John Joensen
     
  5. Phishook

    Phishook LawnSite Bronze Member
    Posts: 1,143

    Sounds good. I'll send you an e-mail or a private message closer to Monday. This is not nessasary, but I do need someone to look at it for some other problems I've been having, so I might take you up on it.

    Thanks,
    Christopher
     

Share This Page